protobuf-c: use generic autoreconf fixup 766/head
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 10 Jan 2015 22:58:36 +0000 (23:58 +0100)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 10 Jan 2015 22:58:36 +0000 (23:58 +0100)
Invoke the generic autoreconf fixup instead of calling the shipped autogen.sh.

This ensures that proper variants of libtoolize, autoconf, automake etc. are
used, otherwise it is not possible to rebuild protobuf-c in the SDK env.

The change requires backport to BB as it currently blocks the rebuild of ocerv.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
libs/protobuf-c/Makefile

index 49aa9f468cca6cae232c9dee201650b0c2411daa..f4af211a8a2d00de1aa19abe0bff915bd007bb00 100644 (file)
@@ -18,6 +18,7 @@ PKG_SOURCE_PROTO:=git
 PKG_SOURCE_VERSION:=$(PKG_VERSION)
 
 PKG_INSTALL:=1
+PKG_FIXUP:=autoreconf
 
 PKG_LICENSE:=BSD-2c
 
@@ -44,11 +45,6 @@ CONFIGURE_ARGS += \
        --enable-static \
        --disable-protoc
 
-define Build/Configure
-       cd $(PKG_BUILD_DIR) && ./autogen.sh
-       $(call Build/Configure/Default)
-endef
-
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/