ola: depend on libftdi1
authorDaniel Golle <daniel@makrotopia.org>
Sun, 30 Sep 2018 21:08:05 +0000 (23:08 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 30 Sep 2018 21:08:05 +0000 (23:08 +0200)
Building against libftdi1 can't be avoided in the presence of libftdi1
headers apparently. As it might be useful for some DMX adapters and
such, depend on libftdi1 from now on.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
net/ola/Makefile

index 7f0ed1409e3e2483bd805c5576cc389c8050e9dd..fec430f9f83d40fb636a48691e35bc8a802df45f 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ola
 PKG_VERSION:=0.10.7
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/OpenLightingProject/ola/tar.gz/$(PKG_VERSION)?
@@ -36,7 +36,7 @@ define Package/ola
   TITLE:=Open Lighting Architecture Daemon
   URL:=https://www.openlighting.org/
   MAINTAINER:=Christian Beier <dontmind@freeshell.org>
-  DEPENDS:=+protobuf +libusb-1.0 +libuuid +libstdcpp +libpthread +librt +zlib +libncurses +liblo +libmicrohttpd
+  DEPENDS:=+protobuf +libftdi1 +libusb-1.0 +libuuid +libstdcpp +libpthread +librt +zlib +libncurses +liblo +libmicrohttpd
 endef
 
 define Package/ola/description
@@ -59,7 +59,6 @@ HOST_CONFIGURE_ARGS += \
        --disable-osc \
        --disable-uart \
        --disable-libusb \
-       --disable-libftdi \
        --disable-http  \
        --disable-examples \
        --disable-unittests \