uvol: add missing quote
authorDaniel Golle <daniel@makrotopia.org>
Wed, 25 Jan 2023 03:33:43 +0000 (03:33 +0000)
committerDaniel Golle <daniel@makrotopia.org>
Wed, 25 Jan 2023 03:34:31 +0000 (03:34 +0000)
Add missing quote which broke the autopart script.

Fixes: b1edbe349 ("uvol: fix regression in handling fractional megabytes free")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
utils/uvol/Makefile
utils/uvol/files/autopart.defaults

index 591a6a6455ca2ee9fa0e754d56973b5b012ac165..256dbfbd1635a74ed2ba5b52f5e17f5b8bb85a04 100644 (file)
@@ -2,7 +2,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uvol
 PKG_VERSION:=0.9
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 PKG_LICENSE:=GPL-2.0-or-later
index 007dd3e2e184f3d5ecc8dda25484d6c940fced16..b403dd6df6205ddcc7b63e88e532fb422fcd5c38 100644 (file)
@@ -62,7 +62,7 @@ get_free_area() {
                        continue
                        ;;
                [0-9]*)
-                       [ $size" -lt $((100 * 1024 * 1024)) ] && continue
+                       [ "$size" -lt $((100 * 1024 * 1024)) ] && continue
                        [ "$found" ] || echo "start=$start, size=$sectors"
                        found=1
                        ;;