file: add newly introduced compression support
authorRosen Penev <rosenp@gmail.com>
Wed, 19 Feb 2020 00:44:44 +0000 (16:44 -0800)
committerRosen Penev <rosenp@gmail.com>
Wed, 19 Feb 2020 00:44:44 +0000 (16:44 -0800)
Also make it explicit in the configure args.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/file/Makefile

index 33d29ce8f11b748080824bfc7cb6b2b3b8d6bfae..1b37784f9c230b9500f818eb81d858256fa93cc6 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=file
 PKG_VERSION:=5.38
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://src.fedoraproject.org/lookaside/pkgs/file/ \
@@ -44,7 +44,7 @@ $(call Package/file/Default)
   SECTION:=libs
   CATEGORY:=Libraries
   TITLE+= library
-  DEPENDS:=+zlib
+  DEPENDS:=+zlib +liblzma +libbz2
 endef
 
 TARGET_CFLAGS += $(FPIC)
@@ -53,6 +53,9 @@ TARGET_LDFLAGS += -Wl,--gc-sections,--as-needed
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-static \
+       --enable-bzlib \
+       --enable-xzlib \
+       --enable-zlib \
        --disable-libseccomp \
        --disable-rpath \
        --disable-warnings \