python-wheel: Add new host-only package
authorJeffery To <jeffery.to@gmail.com>
Tue, 28 Feb 2023 08:19:23 +0000 (16:19 +0800)
committerJeffery To <jeffery.to@gmail.com>
Fri, 31 Mar 2023 05:06:27 +0000 (13:06 +0800)
From the README:

This library is the reference implementation of the Python wheel
packaging standard, as defined in PEP 427.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/python/python-wheel/Makefile [new file with mode: 0644]

diff --git a/lang/python/python-wheel/Makefile b/lang/python/python-wheel/Makefile
new file mode 100644 (file)
index 0000000..abf604a
--- /dev/null
@@ -0,0 +1,48 @@
+#
+# Copyright (C) 2023 Jeffery To
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-wheel
+PKG_VERSION:=0.40.0
+PKG_RELEASE:=1
+
+PYPI_NAME:=wheel
+PKG_HASH:=cd1196f3faee2b31968d626e1731c94f99cbdb67cf5a46e4f5656cbee7738873
+
+PKG_LICENSE:=MIT
+PKG_LICENSE_FILES:=LICENSE.txt
+PKG_MAINTAINER:=Jeffery To <jeffery.to@gmail.com>
+
+PKG_HOST_ONLY:=1
+HOST_BUILD_DEPENDS:=python3/host python-build/host python-installer/host python-flit-core/host
+
+include ../pypi.mk
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+include ../python3-package.mk
+include ../python3-host-build.mk
+
+define Package/python3-wheel
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=A built-package format for Python
+  URL:=https://github.com/pypa/wheel
+  DEPENDS:=+python3-light +python3-email +python3-logging +python3-setuptools
+  BUILDONLY:=1
+endef
+
+define Package/python3-wheel/description
+This library is the reference implementation of the Python wheel
+packaging standard, as defined in PEP 427.
+endef
+
+$(eval $(call Py3Package,python3-wheel))
+$(eval $(call BuildPackage,python3-wheel))
+$(eval $(call BuildPackage,python3-wheel-src))
+$(eval $(call HostBuild))