bwm-ng: fix compilation with GCC 14
authorRosen Penev <rosenp@gmail.com>
Mon, 13 May 2024 03:39:52 +0000 (20:39 -0700)
committerRosen Penev <rosenp@gmail.com>
Tue, 14 May 2024 23:36:58 +0000 (16:36 -0700)
Header is missing.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
net/bwm-ng/Makefile
net/bwm-ng/patches/010-gcc14.patch [new file with mode: 0644]

index 5ff84f2bd89cbe45b223f075f98b25d3740c20bc..5a42fd0267ad41612a9cd67d469466a7da97837c 100644 (file)
@@ -6,7 +6,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bwm-ng
 PKG_VERSION:=0.6.3
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.gropp.org/bwm-ng
diff --git a/net/bwm-ng/patches/010-gcc14.patch b/net/bwm-ng/patches/010-gcc14.patch
new file mode 100644 (file)
index 0000000..0c771b5
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/src/defines.h
++++ b/src/defines.h
+@@ -22,6 +22,7 @@
+ #ifndef __HAVE_DEFINE_H
+ #define __HAVE_DEFINE_H
++#include <ctype.h>
+ #include <stdio.h>
+ #include <stdlib.h>
+ #include <unistd.h>