update ndisc6 to new upstream release (v0.5.0),
authorNicolas Thill <nico@openwrt.org>
Mon, 17 Oct 2005 17:12:02 +0000 (17:12 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 17 Oct 2005 17:12:02 +0000 (17:12 +0000)
change Maintainer field in ipkg/control files,
add tcptraceroute6 subpackage.

SVN-Revision: 2145

openwrt/package/Makefile
openwrt/package/ndisc/Config.in
openwrt/package/ndisc/Makefile
openwrt/package/ndisc/ipkg/ndisc6.control
openwrt/package/ndisc/ipkg/rdisc6.control
openwrt/package/ndisc/ipkg/tcptraceroute6.control [new file with mode: 0644]

index f46f13bdcec29a9ad6eb2df6ce2c1604e01d6dd9..7b0761363251eb5fc42687dc4f964b14b187fe36 100644 (file)
@@ -112,7 +112,7 @@ package-$(BR2_PACKAGE_MTR) += mtr
 package-$(BR2_PACKAGE_MYSQL) += mysql
 package-$(BR2_PACKAGE_NANO) += nano
 package-$(BR2_PACKAGE_NCURSES) += ncurses
-package-$(BR2_PACKAGE_NDISC) += ndisc
+package-$(BR2_COMPILE_NDISC6) += ndisc
 package-$(BR2_PACKAGE_NET_SNMP) += net-snmp
 package-$(BR2_PACKAGE_NETSTAT_NAT) += netstat-nat
 package-$(BR2_PACKAGE_NFS_SERVER) += nfs-server
index 5aea49c8e8e903a2db1d41aacdf80810ad9a69d5..fbf70a9a1b568b99d418248aede6e9a4c34a53da 100644 (file)
@@ -1,30 +1,41 @@
-menu "ndisc - ICMPv6 discovery tools"
+menu "ndisc6 - IPv6 discovery tools"
 
-config BR2_PACKAGE_NDISC
+config BR2_COMPILE_NDISC6
        bool
        default n
-       depends BR2_PACKAGE_NDISC6 || BR2_PACKAGE_RDISC6
+       depends BR2_PACKAGE_NDISC6 || BR2_PACKAGE_RDISC6 || BR2_PACKAGE_TCPTRACEROUTE6
 
 config BR2_PACKAGE_NDISC6
-       tristate "ndisc6 - ICMPv6 neighbour discovery tool"
+       tristate "ndisc6 - an ICMPv6 neighbour discovery tool"
        default m if CONFIG_DEVEL
-       select BR2_PACKAGE_NDISC
+       select BR2_COMPILE_NDISC6
        help
          
-         ICMPv6 neighbour discovery tools
+         An ICMPv6 neighbour discovery tools
          
-         http://people.via.ecp.fr/~rem/ndisc/
+         http://people.via.ecp.fr/~rem/ndisc6/
          
 
 config BR2_PACKAGE_RDISC6
-       tristate "rdisc6 - ICMPv6 router discovery tool"
+       tristate "rdisc6 - an ICMPv6 router discovery tool"
        default m if CONFIG_DEVEL
-       select BR2_PACKAGE_NDISC
+       select BR2_COMPILE_NDISC6
        help
          
-         ICMPv6 router discovery tool
+         An ICMPv6 router discovery tool
          
-         http://people.via.ecp.fr/~rem/ndisc/
+         http://people.via.ecp.fr/~rem/ndisc6/
+         
+
+config BR2_PACKAGE_TCPTRACEROUTE6
+       tristate "tcptraceroute6 - a TCP/IPv6-based traceroute implementation"
+       default m if CONFIG_DEVEL
+       select BR2_COMPILE_NDISC6
+       help
+         
+         A TCP/IPv6-based traceroute implementation
+         
+         http://people.via.ecp.fr/~rem/ndisc6/
          
 
 endmenu
index cde15f218eb2d6f949642e35794f2a2a6c69fe81..d12431c2ad8a6e057a00e9648213e1be717c46c1 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ndisc6
-PKG_VERSION:=0.4.0
+PKG_VERSION:=0.5.0
 PKG_RELEASE:=1
-PKG_MD5SUM:=7c30f2bfdfc4bd7b7c986503083f218d
+PKG_MD5SUM:=affd992b2c797105cac4e2a478ba962d
 
 PKG_SOURCE_URL:=http://people.via.ecp.fr/~rem/ndisc6/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -17,6 +17,7 @@ include $(TOPDIR)/package/rules.mk
 
 $(eval $(call PKG_template,NDISC6,ndisc6,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,RDISC6,rdisc6,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,TCPTRACEROUTE6,tcptraceroute6,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(PKG_BUILD_DIR)/.configured:
        touch $@
@@ -39,3 +40,9 @@ $(IPKG_RDISC6):
        install -m0755 $(PKG_BUILD_DIR)/rdisc6 $(IDIR_RDISC6)/usr/bin/
        $(RSTRIP) $(IDIR_RDISC6)
        $(IPKG_BUILD) $(IDIR_RDISC6) $(PACKAGE_DIR)
+
+$(IPKG_TCPTRACEROUTE6):
+       install -d -m0755 $(IDIR_TCPTRACEROUTE6)/usr/bin
+       install -m0755 $(PKG_BUILD_DIR)/tcptraceroute6 $(IDIR_TCPTRACEROUTE6)/usr/bin/
+       $(RSTRIP) $(IDIR_TCPTRACEROUTE6)
+       $(IPKG_BUILD) $(IDIR_TCPTRACEROUTE6) $(PACKAGE_DIR)
index 91356525e4785bd9dd6348edea5cda99bc8976c6..0704436ff16ac08a56413f7f73cd77bd27471a63 100644 (file)
@@ -3,6 +3,6 @@ Priority: optional
 Section: net
 Version: [TBDL]
 Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
 Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/ndisc/
 Description: ICMPv6 Neighbour Discovery tool
index 05df1176bb3b1988d6986fed1ec84bab6a93ec5f..c37b5c7810d048f926ee21d65f90c4ba756515ea 100644 (file)
@@ -3,6 +3,6 @@ Priority: optional
 Section: net
 Version: [TBDL]
 Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
 Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/ndisc/
 Description: ICMPv6 Router Discovery tool
diff --git a/openwrt/package/ndisc/ipkg/tcptraceroute6.control b/openwrt/package/ndisc/ipkg/tcptraceroute6.control
new file mode 100644 (file)
index 0000000..c3fd2ff
--- /dev/null
@@ -0,0 +1,8 @@
+Package: tcptraceroute6
+Priority: optional
+Section: net
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: OpenWrt Developers Team <openwrt-devel@openwrt.org>
+Source: http://openwrt.org/cgi-bin/viewcvs.cgi/openwrt/package/ndisc/
+Description: A TCP/IPv6-based traceroute implementation