totem-pl-parser: disable libgcrypt
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Wed, 23 Feb 2022 21:32:53 +0000 (22:32 +0100)
committerRosen Penev <rosenp@gmail.com>
Thu, 24 Feb 2022 01:21:49 +0000 (17:21 -0800)
If libgcrypt is compiled first, then it is automatically picked up
during the building totem-pl-parser [1]. Let's disable AmazonAMZ
decoding for now.

[1] https://gitlab.gnome.org/GNOME/totem-pl-parser/-/blob/c6c1c51aefeac28499da9fe5cec4af2278ed1564/meson_options.txt#L3

Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
libs/totem-pl-parser/Makefile

index bba6922b75ff2617cb897e6417c8bc88bd029e00..82a3765b69bdd7f42236686d965ada2a5c7235a0 100644 (file)
@@ -37,7 +37,8 @@ define Package/totem-pl-parser/decription
 endef
 
 MESON_ARGS += -Dintrospection=false \
-              -Denable-libarchive=no
+              -Denable-libarchive=no \
+              -Denable-libgcrypt=no
 
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include/