cgroups-mount,docker-ce,lxc: rework kernel feature dependency
authorYousong Zhou <yszhou4tech@gmail.com>
Tue, 27 Aug 2019 03:42:34 +0000 (03:42 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Thu, 12 Sep 2019 02:31:16 +0000 (10:31 +0800)
Fix that KERNEL_CGROUPS is enabled (selected) automatically along with
cgroups-mount

Replace "if PACKAGE_docker-ce" with a menu to avoid circular denpendency
issue involving PACKAGE_docker-ce, PACKAGE_cgroups-mount and
KERNEL_CGRUOPS

docker-ce, lxc: replace KERNEL_LXC_MISC with more specific options

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
utils/cgroupfs-mount/Makefile
utils/docker-ce/Config.in
utils/lxc/Config.in

index ce021de8d39f536ad619e3b8615feaddc99626f4..03d1088a69f10c1a0186e09749d42d52f2c5da5f 100644 (file)
@@ -10,23 +10,13 @@ PKG_HASH:=d6c8aff7af59c7d0082ee3018c97f73b0421e81a49bb28ad9f66a36da5cd6ec7
 
 PKG_MAINTAINER:=Gerard Ryan <G.M0N3Y.2503@gmail.com>
 
-PKG_BUILD_PARALLEL:=1
-
 include $(INCLUDE_DIR)/package.mk
 
-define Package/cgroupfs-mount/config
-config CGROUPFS_MOUNT_CGROUPS
-       depends on PACKAGE_cgroupfs-mount
-       bool "Enable support for cgroups in the kernel"
-       default y
-       select KERNEL_CGROUPS
-endef
-
 define Package/cgroupfs-mount
   SECTION:=utils
   CATEGORY:=Utilities
   TITLE:=cgroup mount scripts
-  DEPENDS:=+mount-utils
+  DEPENDS:=@KERNEL_CGROUPS +mount-utils
   MENU:=1
 endef
 
index 5c6428e74e7847e9e6bc155872aa0370c84a73c8..b67076efd7363c6a42d0796214d9e7b4c2fa2c5e 100644 (file)
@@ -1,4 +1,4 @@
-if PACKAGE_docker-ce
+menu "Kernel features for Docker"
        config DOCKER_KERNEL_OPTIONS
                bool "Enable Basic kernel support for Docker"
                default n
@@ -9,7 +9,7 @@ if PACKAGE_docker-ce
                select KERNEL_CPUSETS
                select KERNEL_MEMCG
                select KERNEL_KEYS
-               select KERNEL_LXC_MISC
+               select KERNEL_DEVPTS_MULTIPLE_INSTANCES
                select KERNEL_POSIX_MQUEUE
                help
                  Select needed kernel options for Docker. Options include
@@ -81,4 +81,4 @@ if PACKAGE_docker-ce
                        select PACKAGE_kmod-fs-btrfs
                        select KERNEL_BTRFS_FS_POSIX_ACL
        endmenu
-endif
+endmenu
index b655d3e594590944d6f3069a798279b681705d41..ff58ba09602d230771795b08d7a34b70f52a17ac 100644 (file)
@@ -6,7 +6,8 @@ config LXC_KERNEL_OPTIONS
        default n
        select KERNEL_CGROUPS
        select KERNEL_NAMESPACES
-       select KERNEL_LXC_MISC
+       select KERNEL_DEVPTS_MULTIPLE_INSTANCES
+       select KERNEL_POSIX_MQUEUE
        select KERNEL_CGROUP_SCHED
        select KERNEL_FAIR_GROUP_SCHED
        select KERNEL_RT_GROUP_SCHED