golang: Move build cache into $(TMP_DIR)
authorJeffery To <jeffery.to@gmail.com>
Fri, 16 Oct 2020 09:13:42 +0000 (17:13 +0800)
committerJeffery To <jeffery.to@gmail.com>
Fri, 16 Oct 2020 09:13:42 +0000 (17:13 +0800)
This changes the default build cache directory from $(TOPDIR)/.go-build
to $(TMP_DIR)/go-build, so that the cache directory is ignored by git
and is removed by "make dirclean".

This does not move/remove a build cache directory in the previous
location; it will need to be removed manually.

Fixes https://github.com/openwrt/packages/issues/13675.

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
lang/golang/golang-values.mk
lang/golang/golang/Config.in

index 69126a1ed95e0ac340a4a8cfe671a586d735619b..b029ba5b155b704950122d4f2d77948f58a30897 100644 (file)
@@ -236,7 +236,7 @@ endif
 
 # General build info
 
-GO_BUILD_CACHE_DIR:=$(or $(call qstrip,$(CONFIG_GOLANG_BUILD_CACHE_DIR)),$(TOPDIR)/.go-build)
+GO_BUILD_CACHE_DIR:=$(or $(call qstrip,$(CONFIG_GOLANG_BUILD_CACHE_DIR)),$(TMP_DIR)/go-build)
 GO_MOD_CACHE_DIR:=$(DL_DIR)/go-mod-cache
 
 GO_MOD_ARGS= \
index 714bf01fd2b55fc4066a3f83368572623f917890..76fd85c805fcf9c2197ecfb9ff4c20ef1f13bb26 100644 (file)
@@ -17,7 +17,7 @@ config GOLANG_BUILD_CACHE_DIR
        default ""
        help
          Store the Go build cache in this directory.
-         If not set, uses './.go-build'.
+         If not set, uses '$(TMP_DIR)/go-build'.
 
 config GOLANG_MOD_CACHE_WORLD_READABLE
        bool "Ensure Go module cache is world-readable"