ipq40xx: use zImage for EX6100v2 and EX6150v2
authorDavid Bauer <mail@david-bauer.net>
Sat, 13 Jun 2020 14:57:53 +0000 (16:57 +0200)
committerDavid Bauer <mail@david-bauer.net>
Sat, 13 Jun 2020 14:57:53 +0000 (16:57 +0200)
The NETGEAR EX61500v2 and EX6150v2 U-Boot does not support booting LZMA
compressed images. Currently, they are using GZIP compressed kernels,
which results in ledd flash being available to the root and overlay
filesystems.

Using a zImage results in a smaller kernel and therefore increases
available space for rootfs and overlayfs.

Size reduced: ~1.1 MiB

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ipq40xx/image/Makefile

index 1d9f20b85f84cf769f6401d6b59616dd3bc38805..7ca26ba517110242c4a9c56d1f0c9a402f1a176b 100644 (file)
@@ -43,9 +43,7 @@ define Device/UbiFit
 endef
 
 define Device/DniImage
-       KERNEL_SUFFIX := -fit-uImage.itb
-       KERNEL = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
-       KERNEL_NAME := Image
+       $(call Device/FitzImage)
        NETGEAR_BOARD_ID :=
        NETGEAR_HW_ID :=
        IMAGES := factory.img sysupgrade.bin