added new ixp4xx target
authorJohn Crispin <john@openwrt.org>
Tue, 29 Jan 2008 20:07:41 +0000 (20:07 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 29 Jan 2008 20:07:41 +0000 (20:07 +0000)
SVN-Revision: 10314

target/linux/ixp4xx/generic/profiles/500-WifiAP.mk [new file with mode: 0644]

diff --git a/target/linux/ixp4xx/generic/profiles/500-WifiAP.mk b/target/linux/ixp4xx/generic/profiles/500-WifiAP.mk
new file mode 100644 (file)
index 0000000..cbbca80
--- /dev/null
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/WifiAP
+  NAME:=WifiAP
+  PACKAGES:=kmod-madwifi wireless-tools \
+       kmod-scsi-core \
+       kmod-ata-core kmod-ata-artop \
+       kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage \
+       kmod-fs-ext2 kmod-fs-ext3 kmod-fs-vfat gpioctl openslp hostapd wpa-supplicant
+endef
+
+define Profile/WifiAP/Description
+       Full featured image for flash based ixp4xx devices used as industrial APs
+endef
+$(eval $(call Profile,WifiAP))
+