node: bump to v18.16.0
authorHirokazu MORIKAWA <morikw2@gmail.com>
Fri, 14 Apr 2023 04:42:23 +0000 (13:42 +0900)
committerTianling Shen <cnsztl@gmail.com>
Fri, 14 Apr 2023 13:15:16 +0000 (21:15 +0800)
Description:
Update to v18.16.0
Fixed a bug when selecting arm-fpu for vfpv3-d16.

Notable changes
Add initial support for single executable applications
Replace url parser with Ada

Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
lang/node/Makefile
lang/node/patches/999-localhost-no-addrconfig.patch
lang/node/patches/999-revert_enable_pointer_authentication_on_arm64.patch

index 5471d752d6dd3f934a6ed623fcd57c064f21cda5..a0cf9f928a4bc4a83b45d634edea8d339462455b 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=node
-PKG_VERSION:=v18.15.0
+PKG_VERSION:=v18.16.0
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://nodejs.org/dist/$(PKG_VERSION)
-PKG_HASH:=8e44d65018ff973284195c23186469a0ea4082e97ec4200e5f5706d5584daa37
+PKG_HASH:=33d81a233e235a509adda4a4f2209008d04591979de6b3f0f67c1c906093f118
 
 PKG_MAINTAINER:=Hirokazu MORIKAWA <morikw2@gmail.com>, Adrian Panella <ianchi74@outlook.com>
 PKG_LICENSE:=MIT
@@ -118,10 +118,12 @@ CONFIGURE_ARGS:= \
        --shared-libuv \
        --shared-cares \
        --with-intl=$(if $(CONFIG_NODEJS_ICU_SMALL),small-icu,$(if $(CONFIG_NODEJS_ICU_SYSTEM),system-icu,none)) \
-       $(if $(findstring +neon,$(CONFIG_CPU_TYPE)),--with-arm-fpu=neon) \
-       $(if $(findstring +vfp",$(CONFIG_CPU_TYPE)),--with-arm-fpu=vfp) \
-       $(if $(findstring +vfpv3",$(CONFIG_CPU_TYPE)),--with-arm-fpu=vfpv3-d16) \
+       $(if $(findstring +neon",$(CONFIG_CPU_TYPE)),--with-arm-fpu=neon) \
+       $(if $(findstring +neon-vfpv4",$(CONFIG_CPU_TYPE)),--with-arm-fpu=neon) \
        $(if $(findstring +vfpv4",$(CONFIG_CPU_TYPE)),--with-arm-fpu=vfpv3) \
+       $(if $(findstring +vfp",$(CONFIG_CPU_TYPE)),--with-arm-fpu=vfp) \
+       $(if $(findstring +vfpv3",$(CONFIG_CPU_TYPE)),--with-arm-fpu=vfpv3) \
+       $(if $(findstring +vfpv3-d16",$(CONFIG_CPU_TYPE)),--with-arm-fpu=vfpv3-d16) \
        --prefix=/usr
 
 HOST_CONFIGURE_VARS:=
index 50d3f4a1c8140a1c00d10fc1f0875432765891d7..a11ce086c336528c4261f8dc85eeb2ba036e9ab4 100644 (file)
@@ -14,7 +14,7 @@ Forwarded: https://github.com/nodejs/node/issues/33816
  // Permission is hereby granted, free of charge, to any person obtaining a
  // copy of this software and associated documentation files (the
 @@ -1265,13 +1266,6 @@ function lookupAndConnect(self, options)
-     hints: options.hints || 0
+     hints: options.hints || 0,
    };
  
 -  if (!isWindows &&
index d389c30c8940d47a93e9d1bcd34931b3391b5ad1..2d2035618f7f169f511650507d12096deec052af 100644 (file)
@@ -1,6 +1,6 @@
 --- a/configure.py
 +++ b/configure.py
-@@ -1290,7 +1290,6 @@ def configure_node(o):
+@@ -1296,7 +1296,6 @@ def configure_node(o):
  
    # Enable branch protection for arm64
    if target_arch == 'arm64':