python-yaml: fix build with Cython 3
authorkrant <aleksey.vasilenko@gmail.com>
Tue, 20 Feb 2024 11:49:43 +0000 (13:49 +0200)
committerRosen Penev <rosenp@gmail.com>
Sat, 24 Feb 2024 20:20:49 +0000 (12:20 -0800)
Signed-off-by: krant <aleksey.vasilenko@gmail.com>
lang/python/python-yaml/Makefile
lang/python/python-yaml/patches/001-cython3.patch [new file with mode: 0644]

index 837cc8d0d589273007828e0f3cae184b6347896d..92ac328415cdf914b88a4ee5b4c30894e91089f2 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=python-yaml
 PKG_VERSION:=6.0.1
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PYPI_NAME:=PyYAML
 PKG_HASH:=bfdf460b1736c775f2ba9f6a92bca30bc2095067b8a9d77876d1fad6cc3b4a43
diff --git a/lang/python/python-yaml/patches/001-cython3.patch b/lang/python/python-yaml/patches/001-cython3.patch
new file mode 100644 (file)
index 0000000..fe3956c
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/pyproject.toml
++++ b/pyproject.toml
+@@ -1,3 +1,3 @@
+ [build-system]
+-requires = ["setuptools", "wheel", "Cython<3.0"]
++requires = ["setuptools", "wheel", "Cython"]
+ build-backend = "setuptools.build_meta"
+--- a/setup.py
++++ b/setup.py
+@@ -82,7 +82,7 @@ if 'sdist' in sys.argv or os.environ.get
+     with_cython = True
+ try:
+     from Cython.Distutils.extension import Extension as _Extension
+-    from Cython.Distutils import build_ext as _build_ext
++    from Cython.Distutils.old_build_ext import old_build_ext as _build_ext
+     with_cython = True
+ except ImportError:
+     if with_cython: