ramips: enable LZMA loader to fix Linksys RE6500 boot
authorMark King <mark@vemek.co>
Sun, 25 Sep 2022 20:53:52 +0000 (21:53 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 2 Oct 2022 18:21:55 +0000 (20:21 +0200)
At some point after 21.02.3 and before 22.03.0, the size limits of the
Linksys RE6500 were reached and prevent booting from the 22.03.0 release
or builds of current SNAPSHOT. This patch allows builds of master to boot
again and has been tested on my device.

Fixes: #8577
Signed-off-by: Mark King <mark@vemek.co>
target/linux/ramips/image/mt7621.mk

index d7bbedac05415664bb92fd47bdcce3cc3a6c0ed9..92fc9ec12e49024b8f97eaa8da7837cac620da67 100644 (file)
@@ -1270,6 +1270,7 @@ TARGET_DEVICES += linksys_ea8100-v2
 
 define Device/linksys_re6500
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := Linksys
   DEVICE_MODEL := RE6500