adblock: refresh blocklist sources 13283/head
authorDirk Brenken <dev@brenken.org>
Thu, 3 Sep 2020 09:20:52 +0000 (11:20 +0200)
committerDirk Brenken <dev@brenken.org>
Thu, 3 Sep 2020 09:20:52 +0000 (11:20 +0200)
* rename 'smarttv' to 'smarttv_tracking'
* added 'firetv_tracking' and 'android_tracking' (thanks @panache67)
* added 'gaming' (thanks @hasanlo in openwrt forum)
* update readme

Signed-off-by: Dirk Brenken <dev@brenken.org>
net/adblock/Makefile
net/adblock/files/README.md
net/adblock/files/adblock.sources

index 0f5022d67477cb5aa9926123e24967638bddba94..8d2ab9a7595ae4dbc071d70211111f35df4ffae2 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=adblock
 PKG_VERSION:=4.0.6
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Dirk Brenken <dev@brenken.org>
 
index 4d3b14ec66ee6e04ad6d1e50b3ede01e703394df..29a1ff8e704296fecd1a989af70699e0f4569847 100644 (file)
@@ -11,6 +11,7 @@ A lot of people already use adblocker plugins within their desktop browsers, but
 | adaway              | x       | S    | mobile           | [Link](https://github.com/AdAway/adaway.github.io)                                |
 | adguard             | x       | L    | general          | [Link](https://adguard.com)                                                       |
 | anti_ad             |         | L    | compilation      | [Link](https://github.com/privacy-protection-tools/anti-AD/blob/master/README.md) |
+| android_tracking    |         | S    | tracking         | [Link](https://github.com/Perflyst/PiHoleBlocklist)                               |
 | andryou             |         | L    | compilation      | [Link](https://gitlab.com/andryou/block/-/blob/master/readme.md)                  |
 | anudeep             |         | M    | compilation      | [Link](https://github.com/anudeepND/blacklist)                                    |
 | bitcoin             |         | S    | mining           | [Link](https://github.com/hoshsadiq/adblock-nocoin-list)                          |
@@ -20,6 +21,8 @@ A lot of people already use adblocker plugins within their desktop browsers, but
 | energized_porn      |         | XXL  | compilation+porn | [Link](https://energized.pro)                                                     |
 | energized_ultimate  |         | XXL  | compilation      | [Link](https://energized.pro)                                                     |
 | energized_unified   |         | XXL  | compilation      | [Link](https://energized.pro)                                                     |
+| firetv_tracking     |         | S    | tracking         | [Link](https://github.com/Perflyst/PiHoleBlocklist)                               |
+| gaming              |         | S    | gaming           | [Link](https://github.com/abyssin/pihole-blocklist)                               |
 | malwaredomains      |         | M    | malware          | [Link](https://malwaredomains.com)                                                |
 | malwarelist         |         | S    | malware          | [Link](https://www.malwaredomainlist.com)                                         |
 | notracking          |         | XL   | tracking         | [Link](https://github.com/notracking/hosts-blocklists)                            |
@@ -42,7 +45,7 @@ A lot of people already use adblocker plugins within their desktop browsers, but
 | reg_vn              |         | S    | reg_vietnam      | [Link](https://bigdargon.github.io/hostsVN)                                       |
 | shallalist          |         | L    | general          | [Link](https://www.shallalist.de)                                                 |
 | shallalist_porn     |         | XXL  | general+porn     | [Link](https://www.shallalist.de)                                                 |
-| smarttv             |         | S    | smarttv          | [Link](https://github.com/Perflyst/PiHoleBlocklist)                               |
+| smarttv_tracking    |         | S    | tracking         | [Link](https://github.com/Perflyst/PiHoleBlocklist)                               |
 | spam404             |         | S    | general          | [Link](https://github.com/Dawsey21)                                               |
 | stevenblack         |         | L    | compilation      | [Link](https://github.com/StevenBlack/hosts)                                      |
 | stevenblack_porn    |         | L    | compilation+porn | [Link](https://github.com/StevenBlack/hosts)                                      |
index 8a59b7b93bb0d4cf3f8ebdd9e15b8366bbd69622..e198092df0250e1f2183bc4791c54ab3f99f15a3 100644 (file)
                "focus": "general",
                "descurl": "https://adguard.com"
        },
+       "android_tracking": {
+               "url": "https://raw.githubusercontent.com/Perflyst/PiHoleBlocklist/master/android-tracking.txt",
+               "rule": "/^([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
+               "size": "S",
+               "focus": "tracking",
+               "descurl": "https://github.com/Perflyst/PiHoleBlocklist"
+       },
        "andryou": {
                "url": "https://gitlab.com/andryou/block/raw/master/kouhai-compressed-domains",
                "rule": "/^([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
                "focus": "compilation",
                "descurl": "https://energized.pro"
        },
+       "firetv_tracking": {
+               "url": "https://raw.githubusercontent.com/Perflyst/PiHoleBlocklist/master/AmazonFireTV.txt",
+               "rule": "/^([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
+               "size": "S",
+               "focus": "tracking",
+               "descurl": "https://github.com/Perflyst/PiHoleBlocklist"
+       },
+       "gaming": {
+               "url": "https://raw.githubusercontent.com/stopgaming/pihole-blocklist/master/game.txt",
+               "rule": "/^0\\.0\\.0\\.0[[:space:]]+([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($2)}",
+               "size": "S",
+               "focus": "gaming",
+               "descurl": "https://github.com/abyssin/pihole-blocklist"
+       },
        "malwaredomains": {
                "url": "https://mirror1.malwaredomains.com/files/justdomains",
                "rule": "/^([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
                "focus": "general+porn",
                "descurl": "https://www.shallalist.de"
        },
-       "smarttv": {
+       "smarttv_tracking": {
                "url": "https://raw.githubusercontent.com/Perflyst/PiHoleBlocklist/master/SmartTV.txt",
                "rule": "/^([[:alnum:]_-]{1,63}\\.)+[[:alpha:]]+([[:space:]]|$)/{print tolower($1)}",
                "size": "S",
-               "focus": "smarttv",
+               "focus": "tracking",
                "descurl": "https://github.com/Perflyst/PiHoleBlocklist"
        },
        "spam404": {