include/prereq-build: fix ldconfig-stub symlink on macos and BSD OSs
authorChristian Marangi <ansuelsmth@gmail.com>
Tue, 27 Sep 2022 14:54:42 +0000 (16:54 +0200)
committerChristian Marangi <ansuelsmth@gmail.com>
Tue, 27 Sep 2022 14:54:42 +0000 (16:54 +0200)
Some OS may have the true bin to a different location than /bin/true.
BSD based system and macos have true on /usr/bin/true.

Fix this by checking both location and take the one available in the
system.

Reported-by: Sergey V. Lobanov <sergey@lobanov.in>
Suggested-by: Huangbin Zhan <zhanhb88@gmail.com>
Signed-off-by: Christian Marangi <ansuelsmth@gmail.com>
include/prereq-build.mk

index e1687da370dfd7cedc68d4cd9dc8e209b4b9c2b9..c5c2f1c8bb4f64dae4ba9ce464bd1f30e0e75f24 100644 (file)
@@ -213,4 +213,4 @@ prereq: $(STAGING_DIR_HOST)/bin/mkhash $(STAGING_DIR_HOST)/bin/xxd
 
 # Install ldconfig stub
 $(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
-       $(LN) /bin/true $(STAGING_DIR_HOST)/bin/ldconfig))
+       $(LN) $(firstword $(wildcard /bin/true /usr/bin/true)) $(STAGING_DIR_HOST)/bin/ldconfig))