zsh: drop bash syntax in postinst 10815/head
authorKarel Kočí <karel.koci@nic.cz>
Thu, 19 Dec 2019 09:32:25 +0000 (10:32 +0100)
committerKarel Kočí <karel.koci@nic.cz>
Thu, 19 Dec 2019 09:35:33 +0000 (10:35 +0100)
Signed-off-by: Karel Kočí <karel.koci@nic.cz>
utils/zsh/Makefile

index 85b441f9f94ac04522bf1baab2e32d3b7f63800c..a2e37ca1f9e52c008cc9d518f62fbc165ae886b9 100644 (file)
@@ -92,7 +92,7 @@ grep zsh $${IPKG_INSTROOT}/etc/shells || \
        echo "/usr/bin/zsh" >> $${IPKG_INSTROOT}/etc/shells
 
 # Backwards compatibility
-if [[ -e /bin/zsh ]] && ([[ ! -L /bin/zsh ]] || [[ "$(readlink -fn $${IPKG_INSTROOT}/bin/zsh)" != "../$(CONFIGURE_PREFIX)/bin/zsh" ]]); then
+if [ -e /bin/zsh ] && { [ ! -L /bin/zsh ] || [ "$(readlink -fn $${IPKG_INSTROOT}/bin/zsh)" != "../$(CONFIGURE_PREFIX)/bin/zsh" ]; }; then
        ln -fs "../$(CONFIGURE_PREFIX)/bin/zsh" "$${IPKG_INSTROOT}/bin/zsh"
 fi
 endef