libs/libstrophe: install pkg-config .pc file 8621/head
authorEnrico Mioso <mrkiko.rs@gmail.com>
Mon, 8 Apr 2019 08:24:41 +0000 (10:24 +0200)
committerEnrico Mioso <mrkiko.rs@gmail.com>
Mon, 8 Apr 2019 08:24:41 +0000 (10:24 +0200)
This helps packages depending on libs/libstrophe in finding the library via pkg-config or CMake's PKG_SEARCH_MODULE

Signed-off-by: Enrico Mioso <mrkiko.rs@gmail.com>
libs/libstrophe/Makefile

index 091835f33b998d444328d60c48c361db265de3fa..ffb99d0b69d891e6e09cd57cb98f68027eacf928 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libstrophe
 PKG_VERSION:=0.9.2
-PKG_RELEASE=1
+PKG_RELEASE=2
 
 PKG_LICENSE:=GPL-3.0
 PKG_LICENSE_FILES:=COPYING
@@ -56,7 +56,11 @@ define Build/InstallDev
        $(CP) $(PKG_INSTALL_DIR)/usr/include/ $(1)/usr/
 
        $(INSTALL_DIR) $(1)/usr/lib/
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
        $(CP) $(PKG_INSTALL_DIR)/usr/lib/libstrophe.{la,a,so*} $(1)/usr/lib/
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libstrophe.pc \
+               $(1)/usr/lib/pkgconfig/
 endef
 
 define Package/libstrophe/install