apk: disable rootfs repositories during build
authorPaul Spooren <mail@aparcar.org>
Mon, 20 May 2024 15:08:28 +0000 (18:08 +0300)
committerPaul Spooren <mail@aparcar.org>
Mon, 20 May 2024 15:08:28 +0000 (18:08 +0300)
Since we set the root for APK it tries to use those during the build,
which shouldn't happen since local package are used instead.

Disable the repositories by manually setting an empty repository.

Signed-off-by: Paul Spooren <mail@aparcar.org>
include/rootfs.mk

index c2a32fa102dba23603f62137be8eff09d3417a86..9fb7d8cfdfe86c32b284fcf7c031334e2d83a62c 100644 (file)
@@ -47,6 +47,7 @@ apk = \
   IPKG_INSTROOT=$(1) \
   $(FAKEROOT) $(STAGING_DIR_HOST)/bin/apk \
        --root $(1) \
+       --repositories-file /dev/zero \
        --keys-dir $(TOPDIR) \
        --no-cache \
        --no-logfile \