kernel: kmod-iio-sps30: Add I2C driver
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 7 Aug 2022 13:22:42 +0000 (15:22 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 10 Aug 2022 19:36:17 +0000 (21:36 +0200)
The sps30.ko driver was split into a main sps30.ko driver and a
sps30_i2c.ko driver for the I2C interface with kernel 5.14. Add the
sps30_i2c.ko module to the package too.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/iio.mk

index 6a2e0403775fabf353048200c5537169103e5e9b..a4b2ee93e937ec1bdbf5a3fdc96a7e7b2e262167 100644 (file)
@@ -431,9 +431,13 @@ define KernelPackage/iio-sps30
   SUBMENU:=$(IIO_MENU)
   DEPENDS:=+kmod-i2c-core +kmod-iio-core +kmod-industrialio-triggered-buffer +kmod-lib-crc8
   TITLE:=Sensirion SPS30 particulate matter sensor
-  KCONFIG:=CONFIG_SPS30
-  FILES:=$(LINUX_DIR)/drivers/iio/chemical/sps30.ko
-  AUTOLOAD:=$(call AutoProbe,sps30)
+  KCONFIG:= \
+       CONFIG_SPS30 \
+       CONFIG_SPS30_I2C
+  FILES:= \
+       $(LINUX_DIR)/drivers/iio/chemical/sps30.ko \
+       $(LINUX_DIR)/drivers/iio/chemical/sps30_i2c.ko@ge5.14
+  AUTOLOAD:=$(call AutoProbe,sps30 sps30_i2c)
 endef
 
 define KernelPackage/iio-sps30/description