imx6: split up DEVICE_TITLE
authorMoritz Warning <moritzwarning@web.de>
Mon, 9 Sep 2019 22:03:07 +0000 (00:03 +0200)
committerAlexander Couzens <lynxis@fe80.eu>
Wed, 11 Sep 2019 13:19:54 +0000 (15:19 +0200)
DEVICE_TITLE is split up into DEVICE_VENDOR, DEVICE_MODEL and DEVICE_VARIANT

Signed-off-by: Moritz Warning <moritzwarning@web.de>
target/linux/imx6/image/Makefile

index 85d68230215d669cc2cc1ad64ebebe7d6e13262c..b0933d77d20ac87bd82bcd4ef4cadf59a8d67953 100644 (file)
@@ -131,7 +131,9 @@ define Device/Default
 endef
 
 define Device/ventana
-  DEVICE_TITLE := Gateworks Ventana family (normal NAND flash)
+  DEVICE_VENDOR := Gateworks
+  DEVICE_MODEL := Ventana family
+  DEVICE_VARIANT := normal NAND flash
   DEVICE_DTS:= \
        imx6dl-gw51xx \
        imx6dl-gw52xx \
@@ -171,8 +173,10 @@ TARGET_DEVICES += ventana
 
 define Device/ventana-large
   $(Device/ventana)
+  DEVICE_VENDOR := Gateworks
+  DEVICE_MODEL := Ventana family
+  DEVICE_VARIANT := large NAND flash
   DEVICE_NAME := ventana
-  DEVICE_TITLE := Gateworks Ventana family (large NAND flash)
   IMAGES := nand.ubi
   PAGESIZE := 4096
   BLOCKSIZE := 256k
@@ -181,17 +185,19 @@ endef
 TARGET_DEVICES += ventana-large
 
 define Device/wandboard
-  DEVICE_TITLE := Wandboard Dual
+  DEVICE_VENDOR := Wandboard
+  DEVICE_MODEL := Dual
   DEVICE_DTS := imx6dl-wandboard
 endef
 TARGET_DEVICES += wandboard
 
 define Device/cubox-i
+  DEVICE_VENDOR := SolidRun
+  DEVICE_MODEL := CuBox-i
   KERNEL := kernel-bin | install-dtb
   UBOOT := mx6cuboxi
   BOOT_SCRIPT = bootscript-cubox
   DEVICE_NAME := cubox
-  DEVICE_TITLE := SolidRun CuBox-i
   DEVICE_PACKAGES := kmod-drm-imx kmod-drm-imx-hdmi kmod-usb-hid
   DEVICE_DTS := imx6q-cubox-i imx6dl-cubox-i imx6q-hummingboard imx6dl-hummingboard
   IMAGES := combined.bin
@@ -201,7 +207,8 @@ endef
 TARGET_DEVICES += cubox-i
 
 define Device/apalis
-  DEVICE_TITLE := Toradex Apalis family
+  DEVICE_VENDOR := Toradex
+  DEVICE_MODEL := Apalis family
   SUPPORTED_DEVICES := apalis,ixora apalis,eval
   DEVICE_DTS := \
          imx6q-apalis-eval \