gstreamer: Update to 1.20.5
authorKoen Vandeputte <koen.vandeputte@citymesh.com>
Mon, 13 Feb 2023 09:06:27 +0000 (10:06 +0100)
committerRosen Penev <rosenp@gmail.com>
Sun, 26 Feb 2023 02:43:40 +0000 (18:43 -0800)
- allocator: Copy allocator name in gst_allocator_register()
- miniobject: support higher refcount values
- pads: Fix non-serialized sticky event push, e.g. instant change rate events
- padtemplate: Fix annotations
- systemclock: Use futex_time64 syscall on x32 and other platforms that always...
- Fix build of 1.20 branch with Meson 0.64.1 for those who have hotdoc installed on their system.
- meson: fix check for pthread_setname_np()
- -Wimplicit-function-declaration in pthread_setname_np check (missing GNUSOURCE)
- gst-inspect: Don't leak list
- concat: Properly propagate EOS seqnum
- fakesrc: avoid time overflow with datarate

Signed-off-by: Koen Vandeputte <koen.vandeputte@citymesh.com>
multimedia/gstreamer1/Makefile
multimedia/gstreamer1/patches/020-distutils.patch

index 6fe3a639940b2ddab7e1680714fc8606f3389884..41017411e1fe5bc73a546c5b541ea889f9ed6a32 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gstreamer1
-PKG_VERSION:=1.20.4
+PKG_VERSION:=1.20.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=gstreamer-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://gstreamer.freedesktop.org/src/gstreamer
-PKG_HASH:=67c1edf8c3c339cda5dde85f4f7b953bb9607c2d13ae970e2491c5c4c055ef5f
+PKG_HASH:=5a19083faaf361d21fc391124f78ba6d609be55845a82fa8f658230e5fa03dff
 PKG_BUILD_DIR:=$(BUILD_DIR)/gstreamer-$(PKG_VERSION)
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
index 302377854301d0e0ebe1603b95c195e3f8bc5517..76880452d15d02d817f3cf1ddfb92f950abd31db 100644 (file)
@@ -1,6 +1,6 @@
 --- a/meson.build
 +++ b/meson.build
-@@ -527,7 +527,7 @@ if get_option('default_library') == 'sta
+@@ -537,7 +537,7 @@ if get_option('default_library') == 'sta
  endif
  
  # Used in gst/parse/meson.build and below