ath79: add support for devolo WiFi pro 1200i
authorDavid Bauer <mail@david-bauer.net>
Tue, 1 Jan 2019 18:17:23 +0000 (19:17 +0100)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 5 Jan 2019 20:55:22 +0000 (21:55 +0100)
Hardware
--------
CPU:   Qualcomm Atheros QCA9558
RAM:   128M DDR2
FLASH: 16MiB
ETH:   1x Atheros AR8035 (PoE in)
WiFi2: QCA9558 2T2R
WiFi5: QCA9880 2T2R
BTN:   1x Reset
LED:   1x LED blue
       1x LED red
BEEP:  1x GPIO attached piezo beeper
UART:  3.3V GND TX RX (115200-N-8) (3.3V is square pad)
       Header is located next to reset-button

Installation
------------
Make sure you set a password for the root user as prompted on first
setup!

1. Upload OpenWRT sysupgrade image via SSH to the device.
Use /tmp as the destination folder on the device.
User is root, password the one set in the web interface.

2. Install OpenWRT with

> sysupgrade -n -F /tmp/<openwrt-image-name>

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
target/linux/ath79/dts/qca9558_devolo_dvl1200i.dts [new file with mode: 0644]
target/linux/ath79/image/generic.mk

index 0b1a5f39a15f2d7f34a7278f700c3b3c716109b2..3eb0e413f36b1ea757e862857c9fade368200a8a 100755 (executable)
@@ -10,6 +10,7 @@ ath79_setup_interfaces()
 
        case "$board" in
        avm,fritz300e|\
+       devolo,dvl1200i|\
        devolo,dvl1750c|\
        devolo,dvl1750i|\
        ocedo,koala|\
index 9fc0f80569b0dc900001c6008ee0270e93559899..76efa24b52b400de04c9ccf3bd5bdd343a1776da 100644 (file)
@@ -88,6 +88,7 @@ case "$FIRMWARE" in
 "ath10k/cal-pci-0000:00:00.0.bin")
        case $board in
        devolo,dvl1200e|\
+       devolo,dvl1200i|\
        devolo,dvl1750c|\
        devolo,dvl1750i)
                ath10kcal_extract "art" 20480 2116
diff --git a/target/linux/ath79/dts/qca9558_devolo_dvl1200i.dts b/target/linux/ath79/dts/qca9558_devolo_dvl1200i.dts
new file mode 100644 (file)
index 0000000..5900d8b
--- /dev/null
@@ -0,0 +1,51 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9558_devolo_dvl1xxx.dtsi"
+
+/ {
+       compatible = "devolo,dvl1200i", "qca,qca9557";
+       model = "devolo WiFi pro 1200i";
+
+       aliases {
+               led-boot = &status_blue;
+               led-failsafe = &status_red;
+               led-running = &status_blue;
+               led-upgrade = &status_red;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               status_blue: status_blue {
+                       label = "dvl1200i:blue:status";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               status_red: status_red {
+                       label = "dvl1200i:red:status";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       beeper {
+               compatible = "gpio-beeper";
+               gpios = <&gpio 4 GPIO_ACTIVE_HIGH>;
+       };
+};
+
+&eth0 {
+       pll-data = <0xbe000000 0x80000101 0x80001313>;
+};
+
+&gmac_config {
+       rxdv-delay = <3>;
+       rxd-delay = <3>;
+       txen-delay = <3>;
+       txd-delay = <3>;
+       rgmii-enabled = <1>;
+};
index 438a842182f1cd1b10830a87ba79ca116bb420ee..22ba5305b1f9fa5719bf44eb9b92a5efa11f712d 100644 (file)
@@ -170,6 +170,14 @@ define Device/devolo_dvl1200e
 endef
 TARGET_DEVICES += devolo_dvl1200e
 
+define Device/devolo_dvl1200i
+  ATH_SOC := qca9558
+  DEVICE_TITLE := devolo WiFi pro 1200i
+  DEVICE_PACKAGES := kmod-ath10k-ct ath10k-firmware-qca988x-ct
+  IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1200i
+
 define Device/devolo_dvl1750c
   ATH_SOC := qca9558
   DEVICE_TITLE := devolo WiFi pro 1750c