add iptables-snmp package (thanks to Nigel Roberts)
authorNicolas Thill <nico@openwrt.org>
Sun, 6 Nov 2005 23:08:18 +0000 (23:08 +0000)
committerNicolas Thill <nico@openwrt.org>
Sun, 6 Nov 2005 23:08:18 +0000 (23:08 +0000)
SVN-Revision: 2360

openwrt/package/Config.in
openwrt/package/Makefile
openwrt/package/iptables-snmp/Config.in [new file with mode: 0644]
openwrt/package/iptables-snmp/Makefile [new file with mode: 0644]
openwrt/package/iptables-snmp/ipkg/iptables-snmp.control [new file with mode: 0644]

index eb31ce8d57f1a8071fa1c3ae12099e46f71ee243..2b59f05693768eb9e9efd145c39e5d039e37a88a 100644 (file)
@@ -70,6 +70,7 @@ source "package/htpdate/Config.in"
 source "package/iproute2/Config.in"
 source "package/iperf/Config.in"
 source "package/ipset/Config.in"
+source "package/iptables-snmp/Config.in"
 source "package/iptraf/Config.in"
 source "package/kismet/Config.in"
 source "package/l2tpd/Config.in"
index 8cb9ecfbb643628331a51756e046990be8846364..e628961e5ba06a4f0678d97a9454f7dc914d6899 100644 (file)
@@ -62,6 +62,7 @@ package-$(BR2_PACKAGE_IPKG) += ipkg
 package-$(BR2_COMPILE_IPROUTE2) += iproute2
 package-$(BR2_PACKAGE_IPSET) += ipset
 package-$(BR2_COMPILE_IPTABLES) += iptables
+package-$(BR2_PACKAGE_IPTABLES_SNMP) += iptables-snmp
 package-$(BR2_PACKAGE_IPTRAF) += iptraf
 package-$(BR2_PACKAGE_IRSSI) += irssi
 package-$(BR2_COMPILE_JPEG) += jpeg
diff --git a/openwrt/package/iptables-snmp/Config.in b/openwrt/package/iptables-snmp/Config.in
new file mode 100644 (file)
index 0000000..7232abb
--- /dev/null
@@ -0,0 +1,11 @@
+config BR2_PACKAGE_IPTABLES_SNMP
+       prompt "iptables-snmp..................... An snmpd plugin to access iptables rules"
+       tristate
+       default m if CONFIG_DEVEL
+       select BR2_PACKAGE_IPTABLES
+       select BR2_PACKAGE_SNMPD
+       help
+         This is a plugin that makes iptables rules accessable from snmpd.
+         
+         http://www.nobiscuit.com/iptables-snmp/
+
diff --git a/openwrt/package/iptables-snmp/Makefile b/openwrt/package/iptables-snmp/Makefile
new file mode 100644 (file)
index 0000000..269a109
--- /dev/null
@@ -0,0 +1,65 @@
+# $Id$
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=iptables-snmp
+PKG_VERSION:=0.1
+PKG_RELEASE:=1
+PKG_MD5SUM:=8370d2f0c899461a053da491400119d1
+
+PKG_SOURCE_URL:=http://www.nobiscuit.com/iptables-snmp
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_CAT:=zcat
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+include $(TOPDIR)/package/rules.mk
+
+$(eval $(call PKG_template,IPTABLES_SNMP,iptables-snmp,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR); rm -f config.{cache,status}; \
+               $(TARGET_CONFIGURE_OPTS) \
+               CFLAGS="$(TARGET_CFLAGS) " \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
+               ./configure \
+                       --target=$(GNU_TARGET_NAME) \
+                       --host=$(GNU_TARGET_NAME) \
+                       --build=$(GNU_HOST_NAME) \
+                       --program-prefix="" \
+                       --program-suffix="" \
+                       --prefix=/usr \
+                       --exec-prefix=/usr \
+                       --bindir=/usr/bin \
+                       --datadir=/usr/share \
+                       --includedir=/usr/include \
+                       --infodir=/usr/share/info \
+                       --libdir=/usr/lib \
+                       --libexecdir=/usr/lib \
+                       --localstatedir=/var \
+                       --mandir=/usr/share/man \
+                       --sbindir=/usr/sbin \
+                       --sysconfdir=/etc \
+                       $(DISABLE_LARGEFILE) \
+                       $(DISABLE_NLS) \
+       );
+       touch $@
+
+$(PKG_BUILD_DIR)/.built:
+       rm -rf $(PKG_INSTALL_DIR)
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               INSTALL_PREFIX="$(PKG_INSTALL_DIR)" \
+               all install
+       touch $@
+$(IPKG_IPTABLES_SNMP):
+       install -d -m0755 $(IDIR_IPTABLES_SNMP)/usr/lib
+       cp -fpR $(PKG_INSTALL_DIR)/usr/lib/iptables-snmp.so $(IDIR_IPTABLES_SNMP)/usr/lib
+       $(RSTRIP) $(IDIR_IPTABLES_SNMP)
+       $(IPKG_BUILD) $(IDIR_IPTABLES_SNMP) $(PACKAGE_DIR)
+mostlyclean:
+       -$(MAKE) -C $(PKG_BUILD_DIR) clean
+       rm $(PKG_BUILD_DIR)/.built
\ No newline at end of file
diff --git a/openwrt/package/iptables-snmp/ipkg/iptables-snmp.control b/openwrt/package/iptables-snmp/ipkg/iptables-snmp.control
new file mode 100644 (file)
index 0000000..cd92ffe
--- /dev/null
@@ -0,0 +1,5 @@
+Package: iptables-snmp
+Priority: optional
+Section: net
+Depends: snmpd
+Description: An snmpd plugin to access iptables rules
\ No newline at end of file