luci-app-advanced-reboot: bugfix for Linksys E4200v2 5412/head
authorStan Grishin <stangri@melmac.net>
Wed, 6 Oct 2021 21:43:38 +0000 (21:43 +0000)
committerStan Grishin <stangri@melmac.net>
Wed, 6 Oct 2021 21:48:15 +0000 (21:48 +0000)
* bugfix for Linksys E4200v2
* minor code changes

Signed-off-by: Stan Grishin <stangri@melmac.net>
applications/luci-app-advanced-reboot/Makefile
applications/luci-app-advanced-reboot/htdocs/luci-static/resources/view/system/advanced_reboot.js
applications/luci-app-advanced-reboot/root/usr/libexec/rpcd/luci.advanced_reboot
applications/luci-app-advanced-reboot/root/usr/share/advanced-reboot/devices/linksys-e4200v2.json

index a0024cdc1f03dcff3b0880b5c0accd02574ad0aa..114d1cd85973b6fb58e10db8960ae14840fcb1ec 100644 (file)
@@ -5,7 +5,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_LICENSE:=GPL-3.0-or-later
 PKG_MAINTAINER:=Stan Grishin <stangri@melmac.net>
-PKG_VERSION:=1.0.1-2
+PKG_VERSION:=1.0.1-3
 
 LUCI_TITLE:=Advanced Linksys Reboot Web UI
 LUCI_URL:=https://docs.openwrt.melmac.net/luci-app-advanced-reboot/
index f4acb8285dddbc9733b653e66efe030227d23b42..482b8e2e91c65e744946fcc7d1db6219b829f62c 100644 (file)
@@ -197,7 +197,7 @@ return view.extend({
                if (device_info.error)
                        body.appendChild(E('p', { 'class' : 'alert-message warning'}, _("ERROR: ") + this.translateTable[device_info.error]()));
 
-               body.appendChild(E('h3', device_info.device_name + _(' Partitions')));
+               body.appendChild(E('h3', (device_info.device_name || '') + _(' Partitions')));
                if (device_info.device_name) {
                        var partitions_table = E('table', { 'class': 'table' }, [
                                E('tr', { 'class': 'tr table-titles' }, [
index 7ee2ec8ba2bb392d8c2da9a9ac038fc097be0cd9..7ec52a30978bfa99e23a61565f87baaa91cc5beb 100755 (executable)
@@ -1,6 +1,6 @@
 #!/bin/sh
 # Copyright 2017-2020 Stan Grishin (stangri@melmac.net)
-# shellcheck disable=SC2039,SC1091
+# shellcheck disable=SC2039,SC1091,SC3043,SC3057,SC3060
 
 readonly devices_dir="/usr/share/advanced-reboot/devices/"
 
index c32aaf8a3c01f910a0e18c61351e5def6896e891..d42319e2ce818647b934419157e1a6779447ca8d 100644 (file)
@@ -1,7 +1,10 @@
 {
        "vendorName": "Linksys",
        "deviceName": "E4200v2",
-       "boardNames": [ "linksys-e4200v2", "linksys,e4200v2" ],
+       "boardNames": [
+               "linksys-e4200v2",
+               "linksys,e4200-v2"
+       ],
        "partition1MTD": "mtd3",
        "partition2MTD": "mtd5",
        "labelOffset": 32,