Update chillispot to 1.0RC3, uniformize package Makefile, move ipkg related files...
authorNicolas Thill <nico@openwrt.org>
Mon, 18 Apr 2005 21:42:27 +0000 (21:42 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 18 Apr 2005 21:42:27 +0000 (21:42 +0000)
SVN-Revision: 679

openwrt/package/chillispot/Makefile
openwrt/package/chillispot/chillispot.control [deleted file]
openwrt/package/chillispot/ipkg/chillispot.conffiles [new file with mode: 0644]
openwrt/package/chillispot/ipkg/chillispot.control [new file with mode: 0644]
openwrt/package/chillispot/ipkg/chillispot.init [new file with mode: 0644]
openwrt/package/chillispot/ipkg/etc/init.d/S60chilli [deleted file]

index 454105d082f848f96634266742076e99ccc71b36..4b4b8471c55512380439a0bedc91b4c7dd25f483 100644 (file)
@@ -3,77 +3,94 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=chillispot
-PKG_VERSION:=1.0RC2
+PKG_VERSION:=1.0RC3
 PKG_RELEASE:=1
-PKG_MD5SUM:=1b924c0bd592253b1d13af4885ea041a
+PKG_MD5SUM:=9ad5f4181ae2e9e2d5ccb165c37dfdde
 
-PKG_SOURCE_URL:=http://www.chillispot.org/download/
+PKG_SOURCE_URL:= \
+       http://www.chillispot.org/download/ \
+       http://nthill.free.fr/openwrt/sources/$(PKG_NAME)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
 PKG_CAT:=zcat
-PKG_IPK:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-PKG_IPK_DIR:=$(PKG_BUILD_DIR)/ipkg
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
+
+IPKG_CHILLISPOT:=$(PACKAGE_DIR)/$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
+IDIR_CHILLISPOT:=$(PKG_BUILD_DIR)/ipkg/$(PKG_NAME)
+INFO_CHILLISPOT:=$(IPKG_STATE_DIR)/info/$(PKG_NAME).list
 
 $(DL_DIR)/$(PKG_SOURCE):
         $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
 
-$(PKG_BUILD_DIR)/.unpacked: $(DL_DIR)/$(PKG_SOURCE)
+$(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
+       rm -rf $(PKG_BUILD_DIR)
        $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-       touch $(PKG_BUILD_DIR)/.unpacked
+       touch $(PKG_BUILD_DIR)/.prepared
 
-$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.unpacked
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache; \
+$(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
+               CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
+               LDFLAGS="-L$(STAGING_DIR)/usr/lib" \
                ac_cv_func_malloc_0_nonnull=yes \
                ac_cv_func_memcmp_working=yes \
                ac_cv_func_setvbuf_reversed=no \
                ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
+                 --target=$(GNU_TARGET_NAME) \
+                 --host=$(GNU_TARGET_NAME) \
+                 --build=$(GNU_HOST_NAME) \
+                 --program-prefix="" \
+                 --program-suffix="" \
+                 --prefix=/usr \
+                 --exec-prefix=/usr \
+                 --bindir=/usr/bin \
+                 --datadir=/usr/share \
+                 --includedir=/usr/include \
+                 --infodir=/usr/share/info \
+                 --libdir=/usr/lib \
+                 --libexecdir=/usr/lib \
+                 --localstatedir=/var \
+                 --mandir=/usr/share/man \
+                 --sbindir=/usr/sbin \
+                 --sysconfdir=/etc \
+                 $(DISABLE_LARGEFILE) \
+                 $(DISABLE_NLS) \
        );
        touch $(PKG_BUILD_DIR)/.configured
 
-$(PKG_BUILD_DIR)/src/chilli: $(PKG_BUILD_DIR)/.configured
-       $(MAKE) -C $(PKG_BUILD_DIR) $(TARGET_CONFIGURE_OPTS)
+$(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               $(TARGET_CONFIGURE_OPTS)
+       touch $(PKG_BUILD_DIR)/.built
 
-$(PKG_IPK): $(PKG_BUILD_DIR)/src/chilli
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(PKG_IPK_DIR) $(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
-       mkdir -p $(PKG_IPK_DIR)/usr/sbin
-       cp $(PKG_BUILD_DIR)/src/chilli $(PKG_IPK_DIR)/usr/sbin/
-       $(STRIP) $(PKG_IPK_DIR)/usr/sbin/*
-       mkdir -p $(PKG_IPK_DIR)/etc
-       cp $(PKG_BUILD_DIR)/doc/chilli.conf $(PKG_IPK_DIR)/etc
-       cp -a ./ipkg/* $(PKG_IPK_DIR)/
-       find $(PKG_IPK_DIR) -name CVS | xargs rm -rf
-       mkdir -p $(PACKAGE_DIR)
-       $(IPKG_BUILD) $(PKG_IPK_DIR) $(PACKAGE_DIR)
+$(PKG_INSTALL_DIR)/usr/sbin/chilli: $(PKG_BUILD_DIR)/.built
+       mkdir -p $(PKG_INSTALL_DIR)
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               install
+       
+$(IPKG_CHILLISPOT): $(PKG_INSTALL_DIR)/usr/sbin/chilli
+       $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_CHILLISPOT) ./ipkg/$(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+       install -m0644 ./ipkg/$(PKG_NAME).conffiles $(IDIR_CHILLISPOT)/CONTROL/conffiles
+       install -m0755 -d $(IDIR_CHILLISPOT)/etc/init.d
+       install -m0755 ./ipkg/$(PKG_NAME).init $(IDIR_CHILLISPOT)/etc/init.d/chilli
+       install -m0755 -d $(IDIR_CHILLISPOT)/etc
+       install -m0644 $(PKG_BUILD_DIR)/doc/chilli.conf $(IDIR_CHILLISPOT)/etc/
+       install -m0755 -d $(IDIR_CHILLISPOT)/usr/sbin
+       cp -fpR $(PKG_INSTALL_DIR)/usr/sbin/chilli $(IDIR_CHILLISPOT)/usr/sbin/
+       $(RSTRIP) $(IDIR_CHILLISPOT)
+       $(IPKG_BUILD) $(IDIR_CHILLISPOT) $(PACKAGE_DIR)
 
-$(IPKG_STATE_DIR)/info/$(PKG_NAME).list: $(PKG_IPK)
-       $(IPKG) install $(PKG_IPK)
+$(INFO_CHILLISPOT): $(IPKG_CHILLISPOT)
+       $(IPKG) install $(IPKG_CHILLISPOT)
 
 source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.unpacked
-compile: $(PKG_IPK)
-install: $(IPKG_STATE_DIR)/info/$(PKG_NAME).list
+prepare: $(PKG_BUILD_DIR)/.prepared
+compile: $(IPKG_CHILLISPOT)
+install: $(INFO_CHILLISPOT)
 
 clean:
        rm -rf $(PKG_BUILD_DIR)
-       rm -f $(PKG_IPK)
+       rm -rf $(IPKG_CHILLISPOT)
diff --git a/openwrt/package/chillispot/chillispot.control b/openwrt/package/chillispot/chillispot.control
deleted file mode 100644 (file)
index 624dcc5..0000000
+++ /dev/null
@@ -1,7 +0,0 @@
-Package: chillispot
-Priority: optional
-Section: net
-Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
-Source: buildroot-internal
-Description: ChilliSpot is a Wireless LAN Access Point Controller.
-Depends: kmod-tun
diff --git a/openwrt/package/chillispot/ipkg/chillispot.conffiles b/openwrt/package/chillispot/ipkg/chillispot.conffiles
new file mode 100644 (file)
index 0000000..0848516
--- /dev/null
@@ -0,0 +1 @@
+/etc/chilli.conf
diff --git a/openwrt/package/chillispot/ipkg/chillispot.control b/openwrt/package/chillispot/ipkg/chillispot.control
new file mode 100644 (file)
index 0000000..624dcc5
--- /dev/null
@@ -0,0 +1,7 @@
+Package: chillispot
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot-internal
+Description: ChilliSpot is a Wireless LAN Access Point Controller.
+Depends: kmod-tun
diff --git a/openwrt/package/chillispot/ipkg/chillispot.init b/openwrt/package/chillispot/ipkg/chillispot.init
new file mode 100644 (file)
index 0000000..289b1fe
--- /dev/null
@@ -0,0 +1,20 @@
+#!/bin/sh
+
+RUN_D=/var/run
+PID_F=$RUN_D/chilli.pid
+
+case $1 in
+ start)
+  /sbin/insmod tun >/dev/null 2>&1
+  [ -d $RUN_D ] || mkdir -p $RUN_D
+  /usr/sbin/chilli
+  ;;
+ stop)
+  [ -f $PID_F ] && kill $(cat $PID_F) >/dev/null 2>&1
+  ;;
+ *)
+  echo "usage: $0 (start|stop)"
+  exit 1
+esac
+
+exit $?
diff --git a/openwrt/package/chillispot/ipkg/etc/init.d/S60chilli b/openwrt/package/chillispot/ipkg/etc/init.d/S60chilli
deleted file mode 100755 (executable)
index 0fded5b..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-case $1 in
- start)
-  /sbin/insmod tun >/dev/null 2>&1
-  [ -d /var/run ] || mkdir -p /var/run
-  /usr/sbin/chilli
-  ;;
- stop)
-  [ -f /var/run/chilli.pid ] && kill $(cat /var/run/chilli.pid) >/dev/null 2>&1
-  ;;
- *)
-  echo "usage: $0 (start|stop)"
-  exit 1
-esac
-
-exit $?