ramips: use lzma-loader for I-O DATA mt7621 devices
authorINAGAKI Hiroshi <musashino.open@gmail.com>
Sun, 26 Apr 2020 03:24:33 +0000 (12:24 +0900)
committerDavid Bauer <mail@david-bauer.net>
Mon, 27 Apr 2020 10:22:02 +0000 (12:22 +0200)
The official sysupgrade images for I-O DATA devices manufactured by
MSTC (MitraStar Technology Corp.) cannot be booted normally and the
kernel panics after switching to kernel 5.4.

This commit fixes the issue by using lzma-loader.

Note:
  These devices use Z-LOADER to read the kernel from NAND flash and boot
  it. Z-LOADER cannot load and start plain lzma-loader, so additional
  lzma-compression is needed.

Signed-off-by: INAGAKI Hiroshi <musashino.open@gmail.com>
Co-developed-by: Yanase Yuki <dev@zpc.sakura.ne.jp>
Signed-off-by: Yanase Yuki <dev@zpc.sakura.ne.jp>
Tested-by: Yanase Yuki <dev@zpc.sakura.ne.jp> [wn-ax2033gr]
target/linux/ramips/image/mt7621.mk

index abaf3efe2badef33a7755445bbdc31fb150111b1..101e5bbba6be11ab848c17a1549fd6c0b8e0a4d2 100644 (file)
@@ -379,6 +379,8 @@ define Device/iodata_wn-ax1167gr2
   IMAGE_SIZE := 51200k
   DEVICE_VENDOR := I-O DATA
   DEVICE_MODEL := WN-AX1167GR2
+  LOADER_TYPE := bin
+  KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | lzma | uImage lzma
   KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(XBC.1)b10 | \
        iodata-mstc-header
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
@@ -395,6 +397,8 @@ define Device/iodata_wn-ax2033gr
   IMAGE_SIZE := 51200k
   DEVICE_VENDOR := I-O DATA
   DEVICE_MODEL := WN-AX2033GR
+  LOADER_TYPE := bin
+  KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | lzma | uImage lzma
   KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(VST.1)C10 | \
        iodata-mstc-header
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
@@ -411,6 +415,8 @@ define Device/iodata_wn-dx1167r
   IMAGE_SIZE := 51200k
   DEVICE_VENDOR := I-O DATA
   DEVICE_MODEL := WN-DX1167R
+  LOADER_TYPE := bin
+  KERNEL := kernel-bin | append-dtb | lzma | loader-kernel | lzma | uImage lzma
   KERNEL_INITRAMFS := $(KERNEL_DTB) | custom-initramfs-uimage 3.10(XIK.1)b10 | \
        iodata-mstc-header
   IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata