python3-netdisco: add a new package
authorJosef Schlehofer <pepe.schlehofer@gmail.com>
Sun, 21 Apr 2019 13:45:45 +0000 (15:45 +0200)
committerJosef Schlehofer <pepe.schlehofer@gmail.com>
Tue, 23 Apr 2019 15:49:36 +0000 (17:49 +0200)
Signed-off-by: Josef Schlehofer <pepe.schlehofer@gmail.com>
lang/python/python-netdisco/Makefile [new file with mode: 0644]

diff --git a/lang/python/python-netdisco/Makefile b/lang/python/python-netdisco/Makefile
new file mode 100644 (file)
index 0000000..fdcee51
--- /dev/null
@@ -0,0 +1,47 @@
+#
+# Copyright (C) 2019 CZ.NIC, z. s. p. o. (https://www.nic.cz/)
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=python-netdisco
+PKG_VERSION:=2.6.0
+PKG_RELEASE:=1
+
+PKG_SOURCE:=netdisco-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=https://files.pythonhosted.org/packages/source/n/netdisco
+PKG_HASH:=2b3aca14a1807712a053f11fd80dc251dd821ee4899aefece515287981817762
+
+PKG_BUILD_DIR:=$(BUILD_DIR)/netdisco-$(PKG_VERSION)
+
+PKG_MAINTAINER:=Josef Schlehofer <pepe.schlehofer@gmail.com>
+PKG_LICENSE:=Apache-2.0
+PKG_LICENSE_FILES:=LICENSE.md
+
+include $(INCLUDE_DIR)/package.mk
+include ../python3-package.mk
+
+define Package/python3-netdisco
+  SECTION:=lang
+  CATEGORY:=Languages
+  SUBMENU:=Python
+  TITLE:=Discover devices on your local network
+  URL:=https://github.com/home-assistant/netdisco
+  DEPENDS:= \
+         +python3-light \
+         +python3-requests \
+         +python3-zeroconf
+  VARIANT:=python3
+endef
+
+define Package/python3-netdisco/description
+  NetDisco is a Python 3 library to discover local devices and services.
+  It allows to scan on demand or offer a service that will scan the network in the background in a set interval.
+endef
+
+$(eval $(call Py3Package,python3-netdisco))
+$(eval $(call BuildPackage,python3-netdisco))
+$(eval $(call BuildPackage,python3-netdisco-src))