kernel: add kmod-hwmon-sht3x support
authorUwe Kleine-König <uwe@kleine-koenig.org>
Sat, 12 Nov 2022 15:06:52 +0000 (16:06 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Nov 2022 19:47:57 +0000 (20:47 +0100)
The driver supports the temperature and humidity sensors chips SHT3x and
STS3x by Sensirion.

Signed-off-by: Uwe Kleine-König <uwe@kleine-koenig.org>
package/kernel/linux/modules/hwmon.mk

index e0810c97bdcff28f43ea801acae4011b47acf20d..c8d79b622e7acba6bbced73e5db0f7dc4ec95597 100644 (file)
@@ -474,6 +474,21 @@ endef
 $(eval $(call KernelPackage,hwmon-sht21))
 
 
+define KernelPackage/hwmon-sht3x
+  TITLE:=Sensiron SHT3x and compat. monitoring support
+  KCONFIG:=CONFIG_SENSORS_SHT3x
+  FILES:=$(LINUX_DIR)/drivers/hwmon/sht3x.ko
+  AUTOLOAD:=$(call AutoProbe,sht3x)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-lib-crc8)
+endef
+
+define KernelPackage/hwmon-sht3x/description
+ Kernel module for Sensirion SHT3x temperature and humidity sensors chip
+endef
+
+$(eval $(call KernelPackage,hwmon-sht3x))
+
+
 define KernelPackage/hwmon-tmp102
   TITLE:=Texas Instruments TMP102 monitoring support
   KCONFIG:=CONFIG_SENSORS_TMP102