include $(TOPDIR)/rules.mk
PKG_NAME:=cmake
-PKG_VERSION:=3.4.3
+PKG_VERSION:=3.5.1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=https://cmake.org/files/v3.4/ \
+PKG_SOURCE_URL:=https://cmake.org/files/v3.5/ \
https://fossies.org/linux/misc/
-PKG_MD5SUM:=4cb3ff35b2472aae70f542116d616e63
+PKG_MD5SUM:=ca051f4a66375c89d1a524e726da0296
HOST_BUILD_PARALLEL:=1
HOST_CONFIGURE_PARALLEL:=1
--- a/Tests/RunCMake/CMakeLists.txt
+++ b/Tests/RunCMake/CMakeLists.txt
-@@ -216,15 +216,6 @@
+@@ -217,15 +217,6 @@ add_RunCMake_test(interface_library)
add_RunCMake_test(no_install_prefix)
add_RunCMake_test(configure_file)
add_RunCMake_test(FindPkgConfig)
--- a/Tests/CMakeLists.txt
+++ b/Tests/CMakeLists.txt
-@@ -390,10 +390,6 @@
+@@ -389,10 +389,6 @@ if(BUILD_TESTING)
list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
Source/kwsys/SystemInformation.cxx | 9 +++++++++
1 file changed, 9 insertions(+)
-diff --git a/Source/kwsys/SystemInformation.cxx b/Source/kwsys/SystemInformation.cxx
-index 7c31f3a..2672730 100644
--- a/Source/kwsys/SystemInformation.cxx
+++ b/Source/kwsys/SystemInformation.cxx
@@ -90,6 +90,15 @@ typedef int siginfo_t;
#endif
#if defined(__OpenBSD__) || defined(__NetBSD__)
-