libuhttpd: allow building with OpenSSL 3.0
authorEneas U de Queiroz <cotequeiroz@gmail.com>
Thu, 9 Feb 2023 14:25:47 +0000 (11:25 -0300)
committerEneas U de Queiroz <cotequeiroz@gmail.com>
Thu, 16 Feb 2023 13:28:52 +0000 (10:28 -0300)
Add -Wno-error=deprecated-declarations to CFLAGS to allow usage of
deprecated API.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
libs/libuhttpd/Makefile

index 362a0c56e80380598dc9dac0a73c89f26687c2f6..fabe63b895ab8c2793652f72c06cf6eb075fc7e1 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libuhttpd
 PKG_VERSION:=3.14.1
-PKG_RELEASE:=$(AUTORELEASE)
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL=https://github.com/zhaojh329/libuhttpd/releases/download/v$(PKG_VERSION)
@@ -41,6 +41,7 @@ Package/libuhttpd-mbedtls=$(call Package/libuhttpd/Default,mbedtls,+PACKAGE_libu
 Package/libuhttpd-nossl=$(call Package/libuhttpd/Default,nossl)
 
 CMAKE_OPTIONS += -DBUILD_EXAMPLE=OFF
+TARGET_CFLAGS += -Wno-error=deprecated-declarations
 
 ifeq ($(BUILD_VARIANT),openssl)
   CMAKE_OPTIONS += -DUSE_OPENSSL=ON