forked-daapd: fix compilation with GCC10 12721/head
authorRosen Penev <rosenp@gmail.com>
Sat, 4 Jul 2020 19:57:12 +0000 (12:57 -0700)
committerRosen Penev <rosenp@gmail.com>
Sun, 5 Jul 2020 01:12:44 +0000 (18:12 -0700)
Signed-off-by: Rosen Penev <rosenp@gmail.com>
sound/forked-daapd/Makefile
sound/forked-daapd/patches/020-gcc10.patch [new file with mode: 0644]

index 8e911f910460109da1b3d99f654eb6daa018c65f..56919c2cb547354bad6cadb10216cba8fa760f1e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=forked-daapd
 PKG_VERSION:=27.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/ejurgensen/$(PKG_NAME)/releases/download/$(PKG_VERSION)/
diff --git a/sound/forked-daapd/patches/020-gcc10.patch b/sound/forked-daapd/patches/020-gcc10.patch
new file mode 100644 (file)
index 0000000..c0ddeb4
--- /dev/null
@@ -0,0 +1,20 @@
+--- a/src/outputs.h
++++ b/src/outputs.h
+@@ -185,7 +185,7 @@ struct output_data
+   int samples;
+ };
+-struct output_buffer
++static struct output_buffer
+ {
+   struct timespec pts;
+   // The array is two larger than max quality subscriptions because element 0
+@@ -262,7 +262,7 @@ struct output_definition
+ };
+ // Our main list of devices, not for use by backend modules
+-struct output_device *output_device_list;
++static struct output_device *output_device_list;
+ /* ------------------------------- General use ------------------------------ */