crelay: update to 0.10.1
authorTed Hess <thess@kitschensync.net>
Wed, 31 Aug 2016 14:15:09 +0000 (10:15 -0400)
committerTed Hess <thess@kitschensync.net>
Wed, 31 Aug 2016 14:15:09 +0000 (10:15 -0400)
Signed-off-by: Ted Hess <thess@kitschensync.net>
utils/crelay/Makefile
utils/crelay/files/crelay.init
utils/crelay/patches/020-link_using_LDFLAGS.patch [deleted file]
utils/crelay/patches/030-remove_daemonize_call.patch [deleted file]

index 26c7afee9a5e59e6965d0f88731266219b8bc2f9..5e14052c23552857aad95114c1197a6fa9dd3bae 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=crelay
-PKG_VERSION:=0.10
+PKG_VERSION:=0.10.1
 PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=git
index 53183a8cfe84d712ec60f384b6ed6673d93ae762..b7c5123d9514930b464db64b89289ad29c10a014 100644 (file)
@@ -1,5 +1,5 @@
 #!/bin/sh /etc/rc.common
-# Copyright (C) 2015 OpenWrt.org
+# Copyright (C) 2016 OpenWrt.org
 
 NAME=crelay
 START=93
@@ -17,7 +17,7 @@ start_service() {
        procd_set_param respawn
 
        procd_set_param command "$PROG"
-       # daemon mode (not daemonized) - starts HTTP server
+       # daemon mode in foreground - starts HTTP server
        procd_append_param command -d
 
        procd_close_instance
diff --git a/utils/crelay/patches/020-link_using_LDFLAGS.patch b/utils/crelay/patches/020-link_using_LDFLAGS.patch
deleted file mode 100644 (file)
index 5b4a7a2..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/Makefile
-+++ b/src/Makefile
-@@ -64,7 +64,7 @@ all: $(BIN)
- $(BIN):       $(OBJ)
-       @echo "[Link $(BIN)] with libs $(LIBS)"
--      @$(CC) -o $(BIN) $(OBJ) $(LIBS)
-+      @$(CC) -o $(BIN) $(OBJ) $(LDFLAGS) $(LIBS)
- .c.o:
-       @echo "[Compile $<]"
diff --git a/utils/crelay/patches/030-remove_daemonize_call.patch b/utils/crelay/patches/030-remove_daemonize_call.patch
deleted file mode 100644 (file)
index 9b2216e..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- a/src/crelay.c
-+++ b/src/crelay.c
-@@ -678,10 +678,12 @@ int main(int argc, char *argv[])
-       listen(sock, 5);
-       syslog(LOG_DAEMON | LOG_NOTICE, "HTTP server listening on %s:%d\n", inet_ntoa(iface), port);      
-+#if 0
-       if (daemon(0, 0) == -1) {
-             syslog(LOG_DAEMON | LOG_ERR, "Failed to daemonize: %s", strerror(errno));
-             exit(EXIT_FAILURE);
-       }
-+#endif
-       while (1)
-       {