kernel: kmod-nls-cp932: Add nls_euc-jp.ko too
authorHauke Mehrtens <hauke@hauke-m.de>
Fri, 5 Aug 2022 22:45:04 +0000 (00:45 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 10 Aug 2022 19:36:17 +0000 (21:36 +0200)
The CONFIG_NLS_CODEPAGE_932 Config option builds the nls_cp932.ko and
the nls_euc-jp.ko kernel module, package both of them.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
package/kernel/linux/modules/nls.mk

index 05fce27bbc249fa841b50785c7609d16d16020c5..7450ed1ce56754845730412ffcf7f53219c61879 100644 (file)
@@ -135,8 +135,10 @@ define KernelPackage/nls-cp932
   SUBMENU:=Native Language Support
   TITLE:=Codepage 932 (Japanese)
   KCONFIG:=CONFIG_NLS_CODEPAGE_932
-  FILES:=$(LINUX_DIR)/fs/nls/nls_cp932.ko
-  AUTOLOAD:=$(call AutoLoad,25,nls_cp932)
+  FILES:= \
+       $(LINUX_DIR)/fs/nls/nls_cp932.ko \
+       $(LINUX_DIR)/fs/nls/nls_euc-jp.ko
+  AUTOLOAD:=$(call AutoLoad,25,nls_cp932 nls_euc-jp)
   $(call AddDepends/nls)
 endef