11# This is a combination of 2 commits.
authorRosen Penev <rosenp@gmail.com>
Sun, 16 Dec 2018 18:31:02 +0000 (10:31 -0800)
committerRosen Penev <rosenp@gmail.com>
Fri, 24 Jan 2020 07:14:17 +0000 (23:14 -0800)
gammu: Fix build under 64-bit targets.

There's a faulty suffix variable that points to the wrong place.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
(cherry-picked from
bf42426e4a97f3e771de2d3063a4d38f7c8f40e8
5fbc6c873e29dcde6d048ffbbea252411816f884
027ed92f6ed4adb1a90d36c2d3429106b326a53b)

utils/gammu/Makefile

index f2ab0fc9cb3a36824230ae0d7a6e07eceee0ce53..0230674212ecd1ab962e1637f2f57bf4903e2393 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gammu
 PKG_VERSION:=1.37.4
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE_URL:=http://dl.cihar.com/gammu/releases/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
@@ -50,7 +50,7 @@ define Build/InstallDev
        mkdir -p $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/gammu $(1)/usr/include/
        mkdir -p $(1)/usr/lib
-       $(CP)    $(PKG_INSTALL_DIR)/usr/lib$(LIB_SUFFIX)/lib{Gammu*,gsmsd*} $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{Gammu*,gsmsd*} $(1)/usr/lib/
 endef
 
 define Package/gammu/install
@@ -58,7 +58,7 @@ define Package/gammu/install
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gammu $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gammu-{smsd,smsd-inject,smsd-monitor} $(1)/usr/bin
        $(INSTALL_DIR) $(1)/usr/lib
-       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/lib$(LIB_SUFFIX)/lib{Gammu*,gsmsd*} $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/lib{Gammu*,gsmsd*} $(1)/usr/lib
        $(INSTALL_DIR) $(1)/etc/init.d
        $(INSTALL_DIR) $(1)/etc/config
        $(INSTALL_CONF) ./files/gammu $(1)/etc/config/gammu