icu: bump to 71.1 18460/head
authorHirokazu MORIKAWA <morikw2@gmail.com>
Sat, 7 May 2022 02:57:34 +0000 (11:57 +0900)
committerHirokazu MORIKAWA <morikw2@gmail.com>
Sat, 7 May 2022 02:57:34 +0000 (11:57 +0900)
Description:
ICU 71 updates to CLDR 41 locale data with various additions and corrections.

ICU 71 adds phrase-based line breaking for Japanese. Existing line breaking methods follow standards and conventions for body text but do not work well for short Japanese text, such as in titles and headings. This new feature is optimized for these use cases.

ICU 71 adds support for Hindi written in Latin letters (hi_Latn). The CLDR data for this increasingly popular locale has been significantly revised and expanded. Note that based on user expectations, hi_Latn incorporates a large amount of English, and can also be referred to as “Hinglish”

ICU 71 and CLDR 41 are minor releases, mostly focused on bug fixes and small enhancements. (The fall CLDR/ICU releases will update to Unicode 15 which is planned for September.) We are also working to re-establish continuous performance testing for ICU, and on development towards future versions.

ICU 71 updates to the time zone data version 2022a. Note that pre-1970 data for a number of time zones has been removed, as has been the case in the upstream tzdata release since 2021b.

Signed-off-by: Hirokazu MORIKAWA <morikw2@gmail.com>
libs/icu/Makefile
libs/icu/patches/010-max_align_t.patch

index 0289fca97ff003c03dbb6453414ae5603c12f094..239754134e09d8ff47e3739f36902bb428552c97 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=icu4c
-MAJOR_VERSION:=70
+MAJOR_VERSION:=71
 MINOR_VERSION:=1
 PKG_VERSION:=$(MAJOR_VERSION).$(MINOR_VERSION)
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(MAJOR_VERSION)_$(MINOR_VERSION)-src.tgz
 PKG_SOURCE_URL:=https://github.com/unicode-org/icu/releases/download/release-$(MAJOR_VERSION)-$(MINOR_VERSION)
-PKG_HASH:=8d205428c17bf13bb535300669ed28b338a157b1c01ae66d31d0d3e2d47c3fd5
+PKG_HASH:=67a7e6e51f61faf1306b6935333e13b2c48abd8da6d2f46ce6adca24b1e21ebf
 
 PKG_LICENSE:=ICU
 PKG_LICENSE_FILES:=LICENSE
index 6ccb1d6293ee04969723e4be0d277e4f066c2852..e8bd7f4bbeca0a013e9966c654caf1ac6e71ff4f 100644 (file)
@@ -49,7 +49,7 @@
          if (ut == NULL) {
 --- a/tools/toolutil/toolutil.cpp
 +++ b/tools/toolutil/toolutil.cpp
-@@ -266,7 +266,7 @@ struct UToolMemory {
+@@ -267,7 +267,7 @@ struct UToolMemory {
      char name[64];
      int32_t capacity, maxCapacity, size, idx;
      void *array;