asterisk: update to 18.2.2 626/head
authorSebastian Kemper <sebastian_ml@gmx.net>
Sun, 14 Mar 2021 17:14:41 +0000 (18:14 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Sun, 14 Mar 2021 17:14:44 +0000 (18:14 +0100)
Patches removed because uclibc was dropped:

001-disable-semaphores-on-uclibc-otherwise-allow.patch
002-configure-fix-detection-of-re-entrant-resolver-funct.patch

Patches updated/refreshed:

100-build-reproducibly.patch
140-use-default-lua.patch

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/asterisk/Makefile
net/asterisk/patches/001-disable-semaphores-on-uclibc-otherwise-allow.patch [deleted file]
net/asterisk/patches/002-configure-fix-detection-of-re-entrant-resolver-funct.patch [deleted file]
net/asterisk/patches/100-build-reproducibly.patch
net/asterisk/patches/140-use-default-lua.patch

index a9d07213dc8928526d27b9667961a1ce70250690..5bb21b5554f69a8bce5fe9650f6a19520d0c8ab2 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=asterisk
-PKG_VERSION:=18.1.1
-PKG_RELEASE:=5
+PKG_VERSION:=18.2.2
+PKG_RELEASE:=1
 
 PKG_SOURCE:=asterisk-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://downloads.asterisk.org/pub/telephony/asterisk/releases
-PKG_HASH:=d0c0e90379c680a2803b9ba99d35918f5b9522c51998109bcc1937ee53ebdaa3
+PKG_HASH:=c7a3da64e30d1ac428ae2cf4723d3a2b799ae88768341084ce8a2e3e424ae163
 
 PKG_BUILD_DEPENDS:=libxml2/host
 
diff --git a/net/asterisk/patches/001-disable-semaphores-on-uclibc-otherwise-allow.patch b/net/asterisk/patches/001-disable-semaphores-on-uclibc-otherwise-allow.patch
deleted file mode 100644 (file)
index e925416..0000000
+++ /dev/null
@@ -1,28 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -1037,15 +1037,18 @@ AC_LINK_IFELSE(
- # Some platforms define sem_init(), but only support sem_open(). joyous.
- AC_MSG_CHECKING(for working unnamed semaphores)
--AC_RUN_IFELSE(
--      [AC_LANG_PROGRAM([#include <semaphore.h>],
--              [sem_t sem; return sem_init(&sem, 0, 0);])],
-+AC_LINK_IFELSE(
-+      [AC_LANG_PROGRAM(
-+        [#include <semaphore.h>],
-+        [#if defined(__UCLIBC__)
-+         i_dont_exist sem;
-+         #else
-+         sem_t sem;
-+         #endif
-+         return sem_init(&sem, 0, 0);])],
-       AC_MSG_RESULT(yes)
-       AC_DEFINE([HAS_WORKING_SEMAPHORE], 1, [Define to 1 if anonymous semaphores work.]),
--      AC_MSG_RESULT(no),
--      AC_MSG_RESULT(cross-compile)
--      AC_MSG_NOTICE([WARNING: result yes guessed because of cross compilation])
--      AC_DEFINE([HAS_WORKING_SEMAPHORE], 1, [Define to 1 if anonymous semaphores work.])
-+      AC_MSG_RESULT(no)
- )
- LIBS="$save_LIBS"
diff --git a/net/asterisk/patches/002-configure-fix-detection-of-re-entrant-resolver-funct.patch b/net/asterisk/patches/002-configure-fix-detection-of-re-entrant-resolver-funct.patch
deleted file mode 100644 (file)
index fabf423..0000000
+++ /dev/null
@@ -1,33 +0,0 @@
-From 9b4070944578336506cd0a76de6f733c72d0ca74 Mon Sep 17 00:00:00 2001
-From: "Yann E. MORIN" <yann.morin.1998@free.fr>
-Date: Sat, 13 Oct 2018 11:11:15 +0200
-Subject: [PATCH] configure: fix detection of re-entrant resolver functions
-
-Fixes https://issues.asterisk.org/jira/browse/ASTERISK-21795
-
-uClibc does not provide res_nsearch:
-asterisk-16.0.0/main/dns.c:506: undefined reference to `res_nsearch'
-
-Patch coded by Yann E. MORIN:
-http://lists.busybox.net/pipermail/buildroot/2018-October/232630.html
-
-Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
----
- configure.ac | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
---- a/configure.ac
-+++ b/configure.ac
-@@ -1431,7 +1431,11 @@ AC_LINK_IFELSE(
-                       #include <arpa/nameser.h>
-                       #endif
-                       #include <resolv.h>],
--                      [int foo = res_ninit(NULL);])],
-+                      [
-+                              int foo;
-+                              foo = res_ninit(NULL);
-+                              foo = res_nsearch(NULL, NULL, 0, 0, NULL, 0);
-+                      ])],
-       AC_MSG_RESULT(yes)
-       AC_DEFINE([HAVE_RES_NINIT], 1, [Define to 1 if your system has the re-entrant resolver functions.])
-       AC_SEARCH_LIBS(res_9_ndestroy, resolv)
index 736fd5d017a9f87429742953d48f20db81072fb7..7ffa74a46265e4a0cee2a55e180feba221f4deba 100644 (file)
@@ -17,7 +17,7 @@
   * build.h
 --- a/Makefile
 +++ b/Makefile
-@@ -488,7 +488,7 @@ doc/core-en_US.xml: makeopts .lastclean
+@@ -489,7 +489,7 @@ doc/core-en_US.xml: makeopts .lastclean
        @echo "<docs xmlns:xi=\"http://www.w3.org/2001/XInclude\">" >> $@
        @for x in $(MOD_SUBDIRS); do \
                printf "$$x " ; \
index 52d024952652e338bc0fbf384d633fd41a93c675..78ba140fb6327e6df15c33808f25fa75a8cf4611 100644 (file)
@@ -1,15 +1,11 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -2564,7 +2564,11 @@ if test -z "$__opus_include" -o x"$__opu
+@@ -2560,7 +2560,7 @@ if test -z "$__opus_include" -o x"$__opu
  fi
  AST_EXT_LIB_CHECK([OPUSFILE], [opusfile], [op_open_callbacks], [opus/opusfile.h], [], [$__opus_include])
  
--for ver in 5.4 5.3 5.2 5.1; do
-+# This does not work for us. We have both liblua and liblua5.3 in
-+# $(STAGING_DIR)/usr. But the headers for liblua5.3 are in
-+# (STAGING_DIR)/usr/include/lua5.3. Using the below, Asterisk would
-+# use the headers from liblua and link against liblua5.3 :/
-+for ver in ; do
+-for ver in ${LUA_VERSIONS:-5.4 5.3 5.2 5.1}; do
++for ver in ${LUA_VERSIONS}; do
        AST_EXT_LIB_CHECK([LUA], lua${ver}, [luaL_newstate], lua${ver}/lua.h, [-lm])
        if test "x${PBX_LUA}" = "x1" ; then
                if test x"${LUA_DIR}" = x; then