projects
/
openwrt
/
openwrt.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
4096da3
)
include arpfilter and arp_mangle in the kmod-arptables modules (#5410)
author
Florian Fainelli
<florian@openwrt.org>
Sun, 28 Jun 2009 06:18:22 +0000
(06:18 +0000)
committer
Florian Fainelli
<florian@openwrt.org>
Sun, 28 Jun 2009 06:18:22 +0000
(06:18 +0000)
SVN-Revision: 16600
package/kernel/modules/netfilter.mk
patch
|
blob
|
history
diff --git
a/package/kernel/modules/netfilter.mk
b/package/kernel/modules/netfilter.mk
index 101550eac8c7e189e7ff73e72773bda8bd3335ae..dc839e23b0c22cd6a0677320752e8182293799eb 100644
(file)
--- a/
package/kernel/modules/netfilter.mk
+++ b/
package/kernel/modules/netfilter.mk
@@
-371,7
+371,9
@@
define KernelPackage/arptables
SUBMENU:=$(NF_MENU)
TITLE:=ARP firewalling modules
FILES:=$(LINUX_DIR)/net/ipv4/netfilter/arp*.$(LINUX_KMOD_SUFFIX)
- KCONFIG:=CONFIG_IP_NF_ARPTABLES
+ KCONFIG:=CONFIG_IP_NF_ARPTABLES \
+ CONFIG_IP_NF_ARPFILTER \
+ CONFIG_IP_NF_ARP_MANGLE
AUTOLOAD:=$(call AutoLoad,49,$(notdir $(patsubst %.ko,%,$(wildcard $(LINUX_DIR)/net/ipv4/netfilter/arp*.$(LINUX_KMOD_SUFFIX)))))
endef