gst1-plugins-bad: update to 1.17.1
authorRosen Penev <rosenp@gmail.com>
Wed, 24 Jun 2020 00:22:30 +0000 (17:22 -0700)
committerRosen Penev <rosenp@gmail.com>
Mon, 29 Jun 2020 22:24:18 +0000 (15:24 -0700)
Updated options.

Disabled yadif as it fails to compile.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
multimedia/gst1-plugins-bad/Makefile

index ea29e1ea3e22cb7c1fef4b7ffbb70b90a4f5bc62..227b74bebefa359fe313de1e8856e0b8476d8ff7 100644 (file)
@@ -8,13 +8,13 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gst1-plugins-bad
-PKG_VERSION:=1.16.2
+PKG_VERSION:=1.17.1
 PKG_RELEASE:=1
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/gst-plugins-bad-$(PKG_VERSION)
 PKG_SOURCE:=gst-plugins-bad-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://gstreamer.freedesktop.org/src/gst-plugins-bad/
-PKG_HASH:=f1cb7aa2389569a5343661aae473f0a940a90b872001824bc47fa8072a041e74
+PKG_HASH:=598937c818d0955543318203faa28d826eb68d487934be4737e999ad272210d0
 
 PKG_MAINTAINER:=W. Michael Petullo <mike@flyn.org> \
                Ted Hess <thess@kitschensync.net>
@@ -97,6 +97,7 @@ GST_COND_SELECT = -D$(1)=$(if $(CONFIG_PACKAGE_gst1-mod-$(1)),en,dis)abled
 GST_VERSION:=1.0
 
 MESON_ARGS += \
+       $(call GST_COND_SELECT,accurip) \
        $(call GST_COND_SELECT,adpcmdec) \
        $(call GST_COND_SELECT,adpcmenc) \
        $(call GST_COND_SELECT,aiff) \
@@ -111,6 +112,7 @@ MESON_ARGS += \
        -Dcamerabin2=$(if $(CONFIG_PACKAGE_gst1-mod-camerabin),en,dis)abled \
        $(call GST_COND_SELECT,coloreffects) \
        -Ddebugutils=$(if $(CONFIG_PACKAGE_gst1-mod-debugutilsbad),en,dis)abled \
+       $(call GST_COND_SELECT,dvbsubenc) \
        $(call GST_COND_SELECT,dvbsuboverlay) \
        $(call GST_COND_SELECT,dvdspu) \
        $(call GST_COND_SELECT,faceoverlay) \
@@ -148,6 +150,7 @@ MESON_ARGS += \
        $(call GST_COND_SELECT,smooth) \
        $(call GST_COND_SELECT,speed) \
        $(call GST_COND_SELECT,subenc) \
+       $(call GST_COND_SELECT,switchbin) \
        $(call GST_COND_SELECT,timecode) \
        -Dvideofilters=$(if $(CONFIG_PACKAGE_gst1-mod-videofiltersbad),en,dis)abled \
        $(call GST_COND_SELECT,videoframe_audiolevel) \
@@ -155,13 +158,13 @@ MESON_ARGS += \
        $(call GST_COND_SELECT,videosignal) \
        $(call GST_COND_SELECT,vmnc) \
        -Dy4m=$(if $(CONFIG_PACKAGE_gst1-mod-y4mdec),en,dis)abled \
-       $(call GST_COND_SELECT,yadif) \
        \
        -Dopencv=disabled \
        -Dwayland=disabled \
        -Dx11=disabled \
        \
        -Daom=disabled \
+       -Davtp=disabled \
        -Dandroidmedia=disabled \
        -Dapplemedia=disabled \
        -Dassrender=disabled \
@@ -174,6 +177,7 @@ MESON_ARGS += \
        -Dcurl=disabled \
        -Dcurl-ssh2=disabled \
        -Dd3dvideosink=disabled \
+       -Dd3d11=disabled \
        -Ddash=disabled \
        -Ddc1394=disabled \
        -Ddecklink=disabled \
@@ -194,18 +198,20 @@ MESON_ARGS += \
        -Dipcpipeline=disabled \
        -Diqa=disabled \
        -Dkate=disabled \
+       -Dkms=disabled \
        -Dladspa=disabled \
        -Dlibde265=disabled \
        -Dlibmms=disabled \
        -Dlv2=disabled \
+       -Dmediafoundation=disabled \
+       -Dmicrodns=disabled \
        -Dmodplug=disabled \
        -Dmpeg2enc=disabled \
        -Dmplex=disabled \
        -Dmsdk=disabled \
        -Dmusepack=disabled \
        -Dneon=disabled \
-       -Dnvdec=disabled \
-       -Dnvenc=disabled \
+       -Dnvcodec=disabled \
        -Dofa=disabled \
        -Dopenal=disabled \
        -Dopenexr=disabled \
@@ -220,6 +226,7 @@ MESON_ARGS += \
        -Drtmp=disabled \
        $(call GST_COND_SELECT,sbc) \
        -Dsctp=disabled \
+       $(call GST_COND_SELECT,shm) \
        -Dsmoothstreaming=disabled \
        $(call GST_COND_SELECT,sndfile) \
        -Dsoundtouch=disabled \
@@ -230,11 +237,11 @@ MESON_ARGS += \
        -Dtinyalsa=disabled \
        -Dttml=disabled \
        -Duvch264=disabled \
-       -Dvdpau=disabled \
        -Dvoaacenc=disabled \
        -Dvoamrwbenc=disabled \
        -Dvulkan=disabled \
        -Dwasapi=disabled \
+       -Dwasapi2=disabled \
        $(call GST_COND_SELECT,webp) \
        -Dwebrtc=disabled \
        -Dwebrtcdsp=disabled \
@@ -243,7 +250,10 @@ MESON_ARGS += \
        -Dwinscreencap=disabled \
        -Dx265=disabled \
        -Dzbar=disabled \
+       -Dzxing=disabled \
        -Dwpe=disabled \
+       -Dmagicleap=disabled \
+       -Dv4l2codecs=disabled \
        \
        $(call GST_COND_SELECT,hls) \
        -Dhls-crypto=nettle \
@@ -253,7 +263,9 @@ MESON_ARGS += \
        -Dorc=disabled \
        -Dgobject-cast-checks=disabled \
        -Dglib-asserts=disabled \
-       -Dglib-checks=disabled
+       -Dglib-checks=disabled \
+       -Dextra-checks=disabled \
+       -Ddoc=disabled
 
 define Package/gst1-plugins-bad/install
        /bin/true
@@ -343,18 +355,13 @@ $(eval $(call GstBuildPlugin,audiomixmatrix,audiomixmatrix support,audio,,))
 $(eval $(call GstBuildPlugin,audiovisualizers,audiovisualizers support,audio,,))
 $(eval $(call GstBuildPlugin,autoconvert,autoconvert support,,,))
 $(eval $(call GstBuildPlugin,bayer,bayer support,video,,))
-$(eval $(call GstBuildPlugin,bluez,bluez support,,,+bluez-libs))
-$(eval $(call GstBuildPlugin,bz2,bzip2 support,,,+libbz2))
 $(eval $(call GstBuildPlugin,camerabin,camerabin support,basecamerabinsrc photography pbutils app,,))
 $(eval $(call GstBuildPlugin,coloreffects,coloreffects support,video,,))
-#$(eval $(call GstBuildPlugin,dataurisrc,dataurisrc support,,,))
 $(eval $(call GstBuildPlugin,debugutilsbad,debugutils support,video,,))
-$(eval $(call GstBuildPlugin,dtls,DTLS support,,,+libopenssl))
+$(eval $(call GstBuildPlugin,dvbsubenc,dvbsubenc support,video,,))
 $(eval $(call GstBuildPlugin,dvbsuboverlay,dvbsuboverlay support,video,,))
 $(eval $(call GstBuildPlugin,dvdspu,dvdspu support,video,,))
-$(eval $(call GstBuildPlugin,faad,faad support,audio,,+libfaad2))
 $(eval $(call GstBuildPlugin,faceoverlay,faceoverlay support,pbutils,,))
-$(eval $(call GstBuildPlugin,fbdevsink,fbdev support,video,,))
 $(eval $(call GstBuildPlugin,festival,festival support,audio,,))
 $(eval $(call GstBuildPlugin,fieldanalysis,fieldanalysis support,audio,,))
 $(eval $(call GstBuildPlugin,freeverb,freeverb support,,,))
@@ -362,7 +369,6 @@ $(eval $(call GstBuildPlugin,frei0r,frei0r support,controller video,,))
 $(eval $(call GstBuildPlugin,gaudieffects,gaudieffects support,audio,,))
 $(eval $(call GstBuildPlugin,gdp,gdp support,,,))
 $(eval $(call GstBuildPlugin,geometrictransform,geometrictransform support,,,))
-$(eval $(call GstBuildPlugin,hls,HLS support,pbutils adaptivedemux,multifile,+libnettle))
 $(eval $(call GstBuildPlugin,id3tag,id3tag support,tag,,))
 $(eval $(call GstBuildPlugin,inter,inter support,,,))
 $(eval $(call GstBuildPlugin,interlace,interlace support,,,))
@@ -378,32 +384,41 @@ $(eval $(call GstBuildPlugin,mpegpsmux,mpegpsmux support,,,))
 #$(eval $(call GstBuildPlugin,mpegtsmux,mpegtsmux support,video,,))
 $(eval $(call GstBuildPlugin,mxf,mxf support,audio video,,))
 $(eval $(call GstBuildPlugin,netsim,netsim support,,,))
-$(eval $(call GstBuildPlugin,opusparse,OPUS streams library,pbutils,,+libopus))
 $(eval $(call GstBuildPlugin,pcapparse,pcapparse support,,,))
 $(eval $(call GstBuildPlugin,pnm,pnm support,video,,))
 $(eval $(call GstBuildPlugin,proxy,proxy support,,,))
 $(eval $(call GstBuildPlugin,removesilence,removesilence support,audio,,))
 $(eval $(call GstBuildPlugin,rfbsrc,librfb support,video,,))
 $(eval $(call GstBuildPlugin,rtponvif,rtponvif support,,,))
-$(eval $(call GstBuildPlugin,sbc,sbc support,audio,,+sbc))
 $(eval $(call GstBuildPlugin,sdpelem,sdp support,rtp sdp,,))
 $(eval $(call GstBuildPlugin,segmentclip,segmentclip support,audio,,))
-$(eval $(call GstBuildPlugin,shm,POSIX shared memory source and sink,,,+librt))
 $(eval $(call GstBuildPlugin,siren,siren support,audio rtp,,))
 $(eval $(call GstBuildPlugin,smooth,smooth support,,,))
-$(eval $(call GstBuildPlugin,sndfile,sndfile support,audio,,+libsndfile))
 $(eval $(call GstBuildPlugin,speed,speed support,audio,,))
 $(eval $(call GstBuildPlugin,subenc,subenc support,controller,,))
-#$(eval $(call GstBuildPlugin,srtp,srtp support,rtp,,+libsrtp))
+$(eval $(call GstBuildPlugin,switchbin,switchbin support,,,))
 $(eval $(call GstBuildPlugin,timecode,timecode support,,,))
 $(eval $(call GstBuildPlugin,videofiltersbad,videofiltersbad support,,,))
 $(eval $(call GstBuildPlugin,videoframe_audiolevel,videoframe_audiolevel support,,,))
 #$(eval $(call GstBuildPlugin,videoparsersbad,videoparsersbad support,,,))
 $(eval $(call GstBuildPlugin,videosignal,videosignal support,,,))
 $(eval $(call GstBuildPlugin,vmnc,vmnc support,,,))
-$(eval $(call GstBuildPlugin,webp,webp support,,,+libwebp))
 $(eval $(call GstBuildPlugin,y4mdec,y4mdec support,,,))
-$(eval $(call GstBuildPlugin,yadif,yadif support,,,))
+
+$(eval $(call GstBuildPlugin,bluez,bluez support,,,+bluez-libs))
+#$(eval $(call GstBuildPlugin,bz2,bzip2 support,,,+libbz2))
+#$(eval $(call GstBuildPlugin,dataurisrc,dataurisrc support,,,))
+$(eval $(call GstBuildPlugin,dtls,DTLS support,,,+libopenssl))
+$(eval $(call GstBuildPlugin,faad,faad support,audio,,+libfaad2))
+$(eval $(call GstBuildPlugin,fbdevsink,fbdev support,video,,))
+$(eval $(call GstBuildPlugin,hls,HLS support,pbutils adaptivedemux,multifile,+libnettle))
+$(eval $(call GstBuildPlugin,opusparse,OPUS streams library,pbutils,,+libopus))
+$(eval $(call GstBuildPlugin,sbc,sbc support,audio,,+sbc))
+$(eval $(call GstBuildPlugin,shm,POSIX shared memory source and sink,,,+librt))
+$(eval $(call GstBuildPlugin,sndfile,sndfile support,audio,,+libsndfile))
+#$(eval $(call GstBuildPlugin,srtp,srtp support,rtp,,+libsrtp))
+$(eval $(call GstBuildPlugin,webp,webp support,,,+libwebp))
+#$(eval $(call GstBuildPlugin,yadif,yadif support,,,))
 
 $(eval $(call BuildPackage,gstreamer1-plugins-bad))
 $(eval $(call BuildPackage,gst1-plugins-bad))