lvm2: depend on libselinux
authorDaniel Golle <daniel@makrotopia.org>
Fri, 14 Aug 2020 00:42:40 +0000 (01:42 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 14 Aug 2020 00:45:39 +0000 (01:45 +0100)
LVM2 uses libselinux if found at buildtime and then requires it to
be present on run-time.
As LVM2 is usually not installed on space-constraint systems just
always build with libselinux as apart from the extra space usage it
doesn't hurt.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
utils/lvm2/Makefile

index f9134ff82c8d3a29a31b38bf1d0fcb498d21189c..2ecbab7908cf818ec9953cb039f37f3d6e049c33 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=LVM2
 PKG_VERSION:=2.03.09
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=https://sourceware.org/pub/lvm2
@@ -31,7 +31,7 @@ define Package/libdevmapper
   CATEGORY:=Libraries
   TITLE:=The Linux Kernel Device Mapper userspace library
   URL:=https://sourceware.org/dm/
-  DEPENDS:=+kmod-dm +libpthread +libuuid +librt +libblkid
+  DEPENDS:=+kmod-dm +libpthread +libuuid +librt +libblkid +libselinux
 endef
 
 define Package/libdevmapper/description