hfsprogs: remove unused libbsd
authorGuilherme Janczak <guilherme.janczak@yandex.com>
Thu, 28 Jul 2022 05:49:46 +0000 (05:49 +0000)
committerRosen Penev <rosenp@gmail.com>
Thu, 28 Jul 2022 19:17:20 +0000 (12:17 -0700)
hfsprogs uses libbsd for strlcpy(), but the strlcpy() calls are inside
`#ifdef` and don't show up on the OpenWRT package.

Signed-off-by: Guilherme Janczak <guilherme.janczak@yandex.com>
utils/hfsprogs/Makefile

index 7a326d019ed33b0b3399a23abfafeef66f0497da..fd4b00b098cb8947fe940d3185b323919904e0a7 100644 (file)
@@ -28,7 +28,7 @@ define Package/hfsprogs/Default
   SECTION:=utils
   CATEGORY:=Utilities
   SUBMENU:=Filesystem
-  DEPENDS:=+libopenssl +USE_GLIBC:libbsd
+  DEPENDS:=+libopenssl
 endef
 
 define Package/hfsfsck
@@ -60,7 +60,7 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS+="$(TARGET_CFLAGS) $(TARGET_CPPFLAGS) -I$(PKG_BUILD_DIR)/include -DDEBUG_BUILD=0 -D_FILE_OFFSET_BITS=64 -D LINUX=1 -D BSD=1 -D VERSION=\\\"$(PKG_VERSION)\\\"" \
-               LDFLAGS+="$(TARGET_LDFLAGS) $(if $(CONFIG_USE_GLIBC),-lbsd)" \
+               LDFLAGS+="$(TARGET_LDFLAGS)" \
                all
 endef