Enable hidraw support.
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 24 Apr 2013 09:49:09 +0000 (09:49 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 24 Apr 2013 09:49:09 +0000 (09:49 +0000)
It's needed for dealing with certain UART-to-USB adapters built into
e.g. weather stations, and increases the hid module package only
slightly (e.g. on ar71xx: 35k -> 37k).

Signed-off-by: Danny Baumann <dannybaumann@web.de>
SVN-Revision: 36415

package/kernel/modules/input.mk

index 89575ae78397c62c10af48fcb861a14aca23b31d..db31eb7f914ba8d57147f7826204e06f15f4ce94 100644 (file)
@@ -10,7 +10,7 @@ INPUT_MODULES_MENU:=Input modules
 define KernelPackage/hid
   SUBMENU:=$(INPUT_MODULES_MENU)
   TITLE:=HID Devices
-  KCONFIG:=CONFIG_HID
+  KCONFIG:=CONFIG_HID CONFIG_HIDRAW=y
   FILES:=$(LINUX_DIR)/drivers/hid/hid.ko
   AUTOLOAD:=$(call AutoLoad,61,hid)
   $(call AddDepends/input,+kmod-input-evdev)