restund: remove build timestamp 220/head
authorAlexander Couzens <lynxis@fe80.eu>
Tue, 5 Dec 2017 22:13:54 +0000 (23:13 +0100)
committerAlexander Couzens <lynxis@fe80.eu>
Tue, 5 Dec 2017 22:21:16 +0000 (23:21 +0100)
Build timestamps prevent reproducible builds [0].

[0] https://reproducible-builds.org/docs/timestamps/

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
net/restund/Makefile
net/restund/patches/100-reproducible-builds.patch [new file with mode: 0644]

index bceededf909891962a4cd1f8985aeb1b605e8fcf..d2518cde9a9584ac24feaf131b87d56e8aac6915 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=restund
 PKG_VERSION:=0.4.12
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.creytiv.com/pub
diff --git a/net/restund/patches/100-reproducible-builds.patch b/net/restund/patches/100-reproducible-builds.patch
new file mode 100644 (file)
index 0000000..6179de9
--- /dev/null
@@ -0,0 +1,12 @@
+--- a/modules/status/status.c
++++ b/modules/status/status.c
+@@ -30,9 +30,6 @@ static void server_info(struct mbuf *mb)
+       mbuf_write_str(mb, "<table>\n");
+       mbuf_write_str(mb,
+                      " <tr><td>Version:</td><td>" VERSION "</td></tr>\n");
+-      mbuf_write_str(mb,
+-                     " <tr><td>Built:</td><td>" __DATE__ " " __TIME__
+-                     "</td></tr>\n");
+       mbuf_printf(mb, " <tr><td>Uptime:</td><td>%H</td></tr>\n",
+                   fmt_human_time, &uptime);
+       mbuf_write_str(mb, "</table>\n");