Fix config files getting overwritten in opkg install
authorHannu Nyman <hannu.nyman@iki.fi>
Sat, 10 Dec 2016 09:20:01 +0000 (11:20 +0200)
committerHannu Nyman <hannu.nyman@iki.fi>
Sat, 10 Dec 2016 09:20:01 +0000 (11:20 +0200)
Commit 39ff053890 accidentally removed the conffiles definitions
from luci-base, statistics, splash and diag-devinfo apps.

That has caused existing config files to get overwritten if the
package has been reinstalled via opkg. Additionally, the splash
text files have not been saved in sysupgrade or backup as they
are located outside /etc/config

This commit adds back the conffiles definitions to the respective
packages.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
applications/luci-app-diag-devinfo/Makefile
applications/luci-app-splash/Makefile
applications/luci-app-statistics/Makefile
modules/luci-base/Makefile

index 0424fffa0cdf576fec74ccdd0de2a3272e297a19..1505b621214c8d8e38fa4388cadd5cd51533e424 100644 (file)
@@ -9,6 +9,10 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=LuCI Diagnostics Tools (Device Info)
 LUCI_DEPENDS:=+luci-app-diag-core +smap +netdiscover +mac-to-devinfo +httping +smap-to-devinfo +netdiscover-to-devinfo @BROKEN
 
+define Package/luci-app-diag-devinfo/conffiles
+/etc/config/luci_devinfo
+endef
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 345f8910ff09c17c61afa69c1ad1a70e103cfbcc..5740aa5f7c4364923bbd18b2822bb15204838885 100644 (file)
@@ -9,6 +9,12 @@ include $(TOPDIR)/rules.mk
 LUCI_TITLE:=Freifunk DHCP-Splash application
 LUCI_DEPENDS:=+luci-lib-nixio +tc +kmod-sched +iptables-mod-nat-extra +iptables-mod-ipopt
 
+define Package/luci-app-splash/conffiles
+/etc/config/luci_splash
+/usr/lib/luci-splash/splashtext.html
+/usr/lib/luci-splash/splashtextinclude.html
+endef
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 6c0121e96a649afb410ec011f48a7998f2263be0..008792a5d018078525e53ea21dc62d0d22fd7e96 100644 (file)
@@ -12,6 +12,10 @@ LUCI_DEPENDS:= \
        +collectd-mod-cpu +collectd-mod-memory \
        +collectd-mod-interface +collectd-mod-load +collectd-mod-network
 
+define Package/luci-app-statistics/conffiles
+/etc/config/luci_statistics
+endef
+
 include ../../luci.mk
 
 # call BuildPackage - OpenWrt buildroot signature
index 972a451c696f6a15a4c2429edf2fac2b61778b6b..ce7d40dac75c6ba512c5be7e13fb29ee75039eed 100644 (file)
@@ -24,6 +24,7 @@ include $(INCLUDE_DIR)/host-build.mk
 
 define Package/luci-base/conffiles
 /etc/luci-uploads
+/etc/config/luci
 endef
 
 include ../../luci.mk