libgd: update to 2.3.1 14821/head
authorRosen Penev <rosenp@gmail.com>
Sun, 21 Feb 2021 05:13:08 +0000 (21:13 -0800)
committerRosen Penev <rosenp@gmail.com>
Sun, 21 Feb 2021 05:16:56 +0000 (21:16 -0800)
Remove upstreamed patches. Add one to fix finding libwebp.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
libs/libgd/Makefile
libs/libgd/patches/010-getlib.patch [deleted file]
libs/libgd/patches/010-webp.patch [new file with mode: 0644]
libs/libgd/patches/100-no-cxx.patch
libs/libgd/patches/220-exclude_host_headers.patch [deleted file]

index 012eb4381f53012a2726805a7a0521f5e1cc6774..ead713bc8e9f1c2f978cc197bdda7339a4e0c7eb 100644 (file)
@@ -8,12 +8,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libgd
-PKG_VERSION:=2.3.0
-PKG_RELEASE:=3
+PKG_VERSION:=2.3.1
+PKG_RELEASE:=$(AUTORELEASE)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=https://github.com/$(PKG_NAME)/$(PKG_NAME)/releases/download/gd-$(PKG_VERSION)/
-PKG_HASH:=ecd9155b9a417fb3f837f29e5966323796de247789163761dd72dbf83bfcac58
+PKG_HASH:=9767917d9f818faec4ddd763fe4a4ad9f6322c3d25da290ab2ea3e2ce4b52a7b
 
 PKG_MAINTAINER:=Jo-Philipp Wich <jo@mein.io>
 PKG_LICENSE:=MIT
diff --git a/libs/libgd/patches/010-getlib.patch b/libs/libgd/patches/010-getlib.patch
deleted file mode 100644 (file)
index cf4de33..0000000
+++ /dev/null
@@ -1,55 +0,0 @@
-From 635dd9a3065ed88e1741e6b963044b80e913f96a Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Tue, 24 Mar 2020 08:01:01 +0100
-Subject: [PATCH] distribute getlib.sh
-
----
- config/getlib.sh | 42 ++++++++++++++++++++++++++++++++++++++++++
- 1 file changed, 42 insertions(+)
- create mode 100755 config/getlib.sh
-
---- /dev/null
-+++ b/config/getlib.sh
-@@ -0,0 +1,42 @@
-+#!/bin/sh
-+
-+GETVER="${0%/*}/getver.pl"
-+GDLIB_MAJOR=$("${GETVER}" MAJOR)
-+GDLIB_MINOR=$("${GETVER}" MINOR)
-+GDLIB_REVISION=$("${GETVER}" RELEASE)
-+
-+# Dynamic library version information
-+# See http://www.gnu.org/software/libtool/manual/libtool.html#Updating-version-info
-+
-+GDLIB_LT_CURRENT=3
-+# This is the version where the soname (current above) changes.  We use it
-+# to reset the revision base back to zero.  It's a bit of a pain, but some
-+# systems restrict the revision range below to [0..255] (like OS X).
-+GDLIB_PREV_MAJOR=2
-+GDLIB_PREV_MINOR=2
-+# This isn't 100% correct, but it tends to be a close enough approximation
-+# for how we manage the codebase.  It's rare to do a release that doesn't
-+# modify the library since this project is centered around the library.
-+GDLIB_LT_REVISION=$(( ((GDLIB_MAJOR - GDLIB_PREV_MAJOR) << 6) | ((GDLIB_MINOR - GDLIB_PREV_MINOR) << 3) | GDLIB_REVISION ))
-+GDLIB_LT_AGE=0
-+
-+# The first three fields we feed into libtool and the OS target determines how
-+# they get used.  The last two fields we feed into cmake.  We use the same rules
-+# as Linux SONAME versioning in libtool, but cmake should handle it for us.
-+case $1 in
-+CURRENT)
-+      printf '%s' "${GDLIB_LT_CURRENT}"
-+      ;;
-+REVISION)
-+      printf '%s' "${GDLIB_LT_REVISION}"
-+      ;;
-+AGE)
-+      printf '%s' "${GDLIB_LT_AGE}"
-+      ;;
-+VERSION)
-+      printf '%s' "$(( GDLIB_LT_CURRENT - GDLIB_LT_AGE )).${GDLIB_LT_AGE}.${GDLIB_LT_REVISION}"
-+      ;;
-+SONAME)
-+      printf '%s' "$(( GDLIB_LT_CURRENT - GDLIB_LT_AGE ))"
-+      ;;
-+esac
diff --git a/libs/libgd/patches/010-webp.patch b/libs/libgd/patches/010-webp.patch
new file mode 100644 (file)
index 0000000..1aa49c5
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -116,7 +116,7 @@ else (USE_EXT_GD)
+       endif (ENABLE_ICONV)
+       IF (ENABLE_WEBP)
+-              FIND_PACKAGE(WEBP REQUIRED)
++              FIND_PACKAGE(WebP REQUIRED)
+       ENDIF (ENABLE_WEBP)
+       IF (ENABLE_LIQ)
+@@ -166,10 +166,10 @@ else (USE_EXT_GD)
+               LIST(APPEND PKG_REQUIRES_PRIVATES zlib)
+       ENDIF(ZLIB_FOUND)
+-      IF(WEBP_FOUND)
+-              INCLUDE_DIRECTORIES(${WEBP_INCLUDE_DIR})
++      IF(WebP_FOUND)
++              INCLUDE_DIRECTORIES(${WebP_INCLUDE_DIR})
+               SET(HAVE_LIBWEBP 1)
+-      ENDIF(WEBP_FOUND)
++      ENDIF(WebP_FOUND)
+       IF(PNG_FOUND)
+               INCLUDE_DIRECTORIES(${PNG_INCLUDE_DIR})
index 790ddd4c991e1da75106b80e01c694d8ff0886ef..d73a7ebc6446450ecd6aded6cc764e03a5a98ead 100644 (file)
@@ -18,7 +18,7 @@
        gdtables.c
        gdxpm.c
        jisx0208.h
-@@ -198,7 +194,6 @@ install(FILES
+@@ -204,7 +200,6 @@ install(FILES
        gdfonts.h
        gdfontt.h
        gdfx.h
diff --git a/libs/libgd/patches/220-exclude_host_headers.patch b/libs/libgd/patches/220-exclude_host_headers.patch
deleted file mode 100644 (file)
index 3e6fc6c..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -94,8 +94,6 @@ else (USE_EXT_GD)
-       GV_LT(VERSION GDLIB_LIB_VERSION)
-       MESSAGE(STATUS "gd shared lib version ${GDLIB_LIB_SOVERSION} (${GDLIB_LIB_VERSION})")
--      SET(CMAKE_REQUIRED_INCLUDES "/usr/include" "/usr/local/include")
--
-       include(CheckIncludeFiles)
-       include(CheckIncludeFile)