ipq40xx: convert IMAGE_SIZE/KERNEL_SIZE/BLOCKSIZE to kiB
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 30 Oct 2019 18:44:17 +0000 (19:44 +0100)
committerJohn Crispin <john@phrozen.org>
Sat, 2 Nov 2019 19:51:56 +0000 (20:51 +0100)
This cosmetical patch converts IMAGE_SIZE, KERNEL_SIZE and
BLOCKSIZE definitions to kilobytes, as this is consistent and
easier to read/type.

An exception was made for asus_rt-ac58u, where the IMAGE_SIZE of
20439364 cannot be divided by 1024 (and also does not seem to
match anything in DTS).

Build-tested for all devices.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ipq40xx/image/Makefile

index ef80e68393625fd4239ddf3cb993431cad83cc23..a9c5e625af48392f8881efc96c4402560a04991e 100644 (file)
@@ -124,7 +124,7 @@ define Device/avm_fritzbox-4040
        DEVICE_MODEL := FRITZ!Box 4040
        DEVICE_DTS := qcom-ipq4018-fritz4040
        BOARD_NAME := fritz4040
-       IMAGE_SIZE := 29753344
+       IMAGE_SIZE := 29056k
        UBOOT_PATH := $(STAGING_DIR_IMAGE)/uboot-fritz4040.bin
        UBOOT_PARTITION_SIZE := 524288
        IMAGES = eva.bin sysupgrade.bin
@@ -223,7 +223,7 @@ define Device/engenius_ens620ext
        FW_VER := 3.1.2
        FW_VER_NEW := 3.5.6
        CW_VER := 1.8.99
-       IMAGE_SIZE := 21823488
+       IMAGE_SIZE := 21312k
        KERNEL_SIZE := 5120k
        FILESYSTEMS := squashfs
        IMAGES := sysupgrade.bin factory_30.bin factory_35.bin
@@ -274,8 +274,8 @@ define Device/linksys_ea6350v3
        DEVICE_DTS := qcom-ipq4018-ea6350v3
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       KERNEL_SIZE := 3145728
-       IMAGE_SIZE := 38797312
+       KERNEL_SIZE := 3072k
+       IMAGE_SIZE := 37888k
        UBINIZE_OPTS := -E 5
        IMAGES := factory.bin sysupgrade.bin
        IMAGE/factory.bin := append-kernel | append-uImage-fakehdr filesystem | pad-to $$$${KERNEL_SIZE} | append-ubi | linksys-image type=EA6350v3
@@ -304,7 +304,7 @@ define Device/meraki_mr33
        DEVICE_VENDOR := Cisco Meraki
        DEVICE_MODEL := MR33
        DEVICE_DTS := qcom-ipq4029-mr33
-       BLOCKSIZE := 131072
+       BLOCKSIZE := 128k
        PAGESIZE := 2048
        IMAGES = sysupgrade.bin
        DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct