cobalt: do not build userland with support for mips1
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Oct 2013 22:10:57 +0000 (22:10 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 13 Oct 2013 22:10:57 +0000 (22:10 +0000)
Without specifying -march gcc uses -march=mips1 by default, but that
causes problems when compiling openssl. Use -march=r5000 instead to
compile a userland optimized for the CPU used on this device.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 38386

target/linux/cobalt/Makefile

index 13d3fd05daa3919d2f985d1f80479cd79a43c3a7..527d36dd94bc51acb73fd09eba77b8c10f76b55c 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=cobalt
 BOARDNAME:=Cobalt Microservers
 FEATURES:=targz pci ext4 display
 CPU_TYPE := 5k
-CPU_CFLAGS_5k := -mtune=r5000
+CPU_CFLAGS_5k := -march=r5000
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 LINUX_VERSION:=3.3.8