ramips: use lzma-loader for RT5350F-OLinuXino devices
authorSungbo Eo <mans0n@gorani.run>
Tue, 4 Aug 2020 16:04:59 +0000 (01:04 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sat, 8 Aug 2020 14:13:51 +0000 (16:13 +0200)
The bootloader fails to extract a big kernel, e.g. v5.4 kernel image
with ALL_KMODS enabled. This can be fixed by using lzma-loader.

Signed-off-by: Sungbo Eo <mans0n@gorani.run>
target/linux/ramips/image/rt305x.mk

index b75d9078e53b8e334444122681fd339cfbd90d81..2cda2fa51b98c04deb7b9cd4ac536e86829fcefb 100644 (file)
@@ -767,6 +767,7 @@ endef
 TARGET_DEVICES += nixcore_x1-8m
 
 define Device/olimex_rt5350f-olinuxino
+  $(Device/uimage-lzma-loader)
   SOC := rt5350
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := OLIMEX
@@ -777,6 +778,7 @@ endef
 TARGET_DEVICES += olimex_rt5350f-olinuxino
 
 define Device/olimex_rt5350f-olinuxino-evb
+  $(Device/uimage-lzma-loader)
   SOC := rt5350
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := OLIMEX