measurement-kit: update package 10677/head
authorJan Pavlinec <jan.pavlinec@nic.cz>
Fri, 29 Nov 2019 10:48:01 +0000 (11:48 +0100)
committerJan Pavlinec <jan.pavlinec@nic.cz>
Mon, 2 Dec 2019 14:00:21 +0000 (15:00 +0100)
Changes:
-add InstallDev section
-remove uclibc patch (issue fixed in upstream)

Signed-off-by: Jan Pavlinec <jan.pavlinec@nic.cz>
libs/measurement-kit/Makefile
libs/measurement-kit/patches/010-nextafter.patch [deleted file]

index d7523d48e0c1b33335923db7377aedf5ad854c10..c074dcb137158834aa80ec6fe4d74ec7d49be0d6 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=measurement-kit
 PKG_VERSION:=0.10.6
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=https://codeload.github.com/measurement-kit/measurement-kit/tar.gz/v$(PKG_VERSION)?
@@ -44,6 +44,13 @@ define Build/Configure
        $(call Build/Configure/Default)
 endef
 
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include
+       $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/* $(1)/usr/lib/
+endef
+
 define Package/measurement-kit/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/measurement_kit $(1)/usr/bin/
diff --git a/libs/measurement-kit/patches/010-nextafter.patch b/libs/measurement-kit/patches/010-nextafter.patch
deleted file mode 100644 (file)
index b7004a6..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/include/private/catch.hpp
-+++ b/include/private/catch.hpp
-@@ -11095,7 +11095,11 @@ bool almostEqualUlps(FP lhs, FP rhs, int maxUlpDiff) {
- template <typename FP>
- FP step(FP start, FP direction, int steps) {
-     for (int i = 0; i < steps; ++i) {
-+#ifndef __UCLIBC__
-         start = std::nextafter(start, direction);
-+#else
-+        start = ::nextafterf(start, direction);
-+#endif
-     }
-     return start;
- }